summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-04-13 06:30:11 +0200
committerHans de Graaff <graaff@gentoo.org>2020-04-13 06:30:11 +0200
commit79b7d3e01136ecba24b544d83453eee94481b64f (patch)
tree828cdbe5a2e45fa4ff5476173f446b62dce55856 /dev-ruby/slop/slop-4.8.1.ebuild
parentprofiles: p.u.mask mate-base/mate[bluetooth] on arm/arm64 (diff)
downloadgentoo-79b7d3e01136ecba24b544d83453eee94481b64f.tar.gz
gentoo-79b7d3e01136ecba24b544d83453eee94481b64f.tar.bz2
gentoo-79b7d3e01136ecba24b544d83453eee94481b64f.zip
dev-ruby/slop: add 4.8.1
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/slop/slop-4.8.1.ebuild')
-rw-r--r--dev-ruby/slop/slop-4.8.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/slop/slop-4.8.1.ebuild b/dev-ruby/slop/slop-4.8.1.ebuild
new file mode 100644
index 000000000000..aefdfb5d23c7
--- /dev/null
+++ b/dev-ruby/slop/slop-4.8.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="slop.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A simple option parser with an easy to remember syntax and friendly API"
+HOMEPAGE="https://github.com/injekt/slop"
+SRC_URI="https://github.com/injekt/${PN}/archive/v${PV}.tar.gz -> ${P}.tgz"
+
+LICENSE="MIT"
+SLOT="4"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ sed -i -e '/git ls-files/d' slop.gemspec || die
+}