summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-09-11 06:27:10 +0200
committerHans de Graaff <graaff@gentoo.org>2020-09-11 06:27:10 +0200
commit18f8359d435c78ba32a61a7f9cf35693e52bdb72 (patch)
treef45ce213761616f3437d695adbaf2e8aa03f4774 /dev-ruby/slop
parentdev-ruby/ruby_parser: add 3.15.0 (diff)
downloadgentoo-18f8359d435c78ba32a61a7f9cf35693e52bdb72.tar.gz
gentoo-18f8359d435c78ba32a61a7f9cf35693e52bdb72.tar.bz2
gentoo-18f8359d435c78ba32a61a7f9cf35693e52bdb72.zip
dev-ruby/slop: add 4.8.2
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/slop')
-rw-r--r--dev-ruby/slop/Manifest1
-rw-r--r--dev-ruby/slop/slop-4.8.2.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/slop/Manifest b/dev-ruby/slop/Manifest
index 429a86bb7da4..951bc708223d 100644
--- a/dev-ruby/slop/Manifest
+++ b/dev-ruby/slop/Manifest
@@ -1 +1,2 @@
DIST slop-4.8.1.tgz 16805 BLAKE2B 875b9a1895d99147f6d597b976831fcb406170d6172ad4c888f53cb18e35439f9fc6bcf785864a3209de5169166b2760d196e1f2f102308db3aec07950fe5e88 SHA512 4edace1693081ab7f9d1efaeb9c894f34c0012ae827ee13bd1c8014c222e88db20b082be3d6b0a97e664135b2ba09bec9e7ecb0d20c22b32a859ac574fd2b71e
+DIST slop-4.8.2.tgz 16102 BLAKE2B c43af7350346961db1b19db2fbded24dc8a5483cf487f6dd6f6c486f9539984048f43eef7c3152da42b4c833eb9ec75d7ebfd89c7e759e5e5279bd5f69992f6a SHA512 1747981d5723b935f4d2a89787cf090645e43793b7430d43687dde6dc7e0bc8b52c30497f656e360e0cb95d62f3abb19d9dc4aebb617da57de1211104217bdc4
diff --git a/dev-ruby/slop/slop-4.8.2.ebuild b/dev-ruby/slop/slop-4.8.2.ebuild
new file mode 100644
index 000000000000..6618224d5852
--- /dev/null
+++ b/dev-ruby/slop/slop-4.8.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="slop.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A simple option parser with an easy to remember syntax and friendly API"
+HOMEPAGE="https://github.com/injekt/slop"
+SRC_URI="https://github.com/injekt/${PN}/archive/v${PV}.tar.gz -> ${P}.tgz"
+
+LICENSE="MIT"
+SLOT="4"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ sed -i -e '/git ls-files/d' slop.gemspec || die
+}