summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-04-01 08:17:02 +0200
committerHans de Graaff <graaff@gentoo.org>2017-04-01 08:17:51 +0200
commit4455f536ca7e1c74e3925349f1fc07203aff5f76 (patch)
treeea24460e8f6cdb39f43d0a59c832de3a5d991320 /dev-ruby/sshkit/sshkit-1.13.1.ebuild
parentdev-ruby/github_api: cleanup (diff)
downloadgentoo-4455f536ca7e1c74e3925349f1fc07203aff5f76.tar.gz
gentoo-4455f536ca7e1c74e3925349f1fc07203aff5f76.tar.bz2
gentoo-4455f536ca7e1c74e3925349f1fc07203aff5f76.zip
dev-ruby/sshkit: add 1.13.1
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ruby/sshkit/sshkit-1.13.1.ebuild')
-rw-r--r--dev-ruby/sshkit/sshkit-1.13.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-ruby/sshkit/sshkit-1.13.1.ebuild b/dev-ruby/sshkit/sshkit-1.13.1.ebuild
new file mode 100644
index 000000000000..3a34397f996f
--- /dev/null
+++ b/dev-ruby/sshkit/sshkit-1.13.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23"
+
+# There are functional tests that require vagrant boxes to be set up.
+RUBY_FAKEGEM_TASK_TEST="test:units"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md FAQ.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="SSHKit makes it easy to write structured, testable SSH commands in Ruby"
+HOMEPAGE="https://github.com/capistrano/sshkit"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/net-ssh-2.8.0:*
+ >=dev-ruby/net-scp-1.1.2
+"
+
+ruby_add_bdepend "test? ( dev-ruby/minitest dev-ruby/mocha )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/I s:^:#:' Rakefile test/helper.rb || die
+ sed -i -e '/\(turn\|unindent\|reporters\)/I s:^:#:' \
+ -e '1irequire "set"; require "pathname"' test/helper.rb || die
+
+ # Fix assumption about parent directory name
+ sed -i -e '/assert_match/ s/sshkit/sshkit.*/' test/unit/test_deprecation_logger.rb || die
+}
+
+each_ruby_test() {
+ # Run tests directly to avoid dependencies in the Rakefile
+ ${RUBY} -Ilib:test:. -e "Dir['test/unit/**/test*.rb'].each{|f| require f}" || die
+}