summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-08-18 07:27:46 +0200
committerHans de Graaff <graaff@gentoo.org>2017-08-18 07:27:46 +0200
commit5c709d05e1467d7cc86a1a65c8d34aa597dc1b3e (patch)
treea9b17d43e71c8a351b742054bb6bea787435f94b /dev-ruby/thor/thor-0.20.0.ebuild
parentwww-servers/puma: add 3.10.0 (diff)
downloadgentoo-5c709d05e1467d7cc86a1a65c8d34aa597dc1b3e.tar.gz
gentoo-5c709d05e1467d7cc86a1a65c8d34aa597dc1b3e.tar.bz2
gentoo-5c709d05e1467d7cc86a1a65c8d34aa597dc1b3e.zip
dev-ruby/thor: add 0.20.0
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ruby/thor/thor-0.20.0.ebuild')
-rw-r--r--dev-ruby/thor/thor-0.20.0.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/dev-ruby/thor/thor-0.20.0.ebuild b/dev-ruby/thor/thor-0.20.0.ebuild
new file mode 100644
index 000000000000..3c2f9d50058b
--- /dev/null
+++ b/dev-ruby/thor/thor-0.20.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+RUBY_FAKEGEM_BINWRAP="thor"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A scripting framework that replaces rake and sake"
+HOMEPAGE="http://whatisthor.com/"
+
+SRC_URI="https://github.com/erikhuda/${PN}/archive/v${PV}.tar.gz -> ${PN}-git-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~amd64-linux"
+IUSE="doc"
+
+USE_RUBY="ruby21 ruby22 ruby23" ruby_add_bdepend "
+ test? (
+ dev-ruby/childlabor
+ dev-ruby/webmock
+ )"
+
+all_ruby_prepare() {
+ # Remove rspec default options (as we might not have the last
+ # rspec).
+ rm .rspec || die
+
+ # Remove Bundler
+ #rm Gemfile || die
+ sed -i -e '/[Bb]undler/d' Thorfile || die
+
+ # Remove mandatory coverage collection using simplecov which is not
+ # packaged.
+ sed -i -e '/require .simplecov/,/^ end/ s:^:#:' spec/helper.rb || die
+
+ # Avoid a spec that requires UTF-8 support, so LANG=C still works,
+ # bug 430402
+ sed -i -e '/uses maximum terminal width/,/end/ s:^:#:' spec/shell/basic_spec.rb || die
+}
+
+each_ruby_test() {
+ case ${RUBY} in
+ *ruby24)
+ einfo "Skipping tests due to circular dependencies"
+ ;;
+ *)
+ RSPEC_VERSION=3 ruby-ng_rspec spec || die
+ ;;
+ esac
+}