summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-06-10 09:27:13 +0200
committerHans de Graaff <graaff@gentoo.org>2017-06-10 09:31:29 +0200
commit0a874c3e9174cdfc302d2986b8cc511ea0fdcc56 (patch)
tree0fca4fdc3858fea20708f089eff95f2a9557e458 /dev-ruby/thor
parentdev-ruby/mime-types-data: add ruby24 (diff)
downloadgentoo-0a874c3e9174cdfc302d2986b8cc511ea0fdcc56.tar.gz
gentoo-0a874c3e9174cdfc302d2986b8cc511ea0fdcc56.tar.bz2
gentoo-0a874c3e9174cdfc302d2986b8cc511ea0fdcc56.zip
dev-ruby/thor: add 0.19.4
Package-Manager: Portage-2.3.5, Repoman-2.3.1
Diffstat (limited to 'dev-ruby/thor')
-rw-r--r--dev-ruby/thor/Manifest1
-rw-r--r--dev-ruby/thor/thor-0.19.4.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-ruby/thor/Manifest b/dev-ruby/thor/Manifest
index 4948c8bb1c0f..c0b1b8276746 100644
--- a/dev-ruby/thor/Manifest
+++ b/dev-ruby/thor/Manifest
@@ -1 +1,2 @@
DIST thor-git-0.19.1.tgz 86389 SHA256 70013a638aa81df39b579cde7c68a1b6418ffa999e596eb89e12cdab14593dff SHA512 67aeaa2822b462c59ea9fd1a197222ce997b0edd30eb714b0a303c816acff82f4fb10a650b8a3c508c796426517ba25a462551fbc73ed7b33d4e16207cad8991 WHIRLPOOL d32b384b06fa338af345f7b13014dbff1bd5aac347437cfc8af8c33e3a14b0054245458e88b1109d769a6e1feb273ec9a7283459cba937bebfa66e8f6653ea05
+DIST thor-git-0.19.4.tgz 88733 SHA256 a155779f9c72061ccc3dd5087bef2a85202d9238be9c4d19ad53879dad924f16 SHA512 a5cc52b23806e6104b12f924324960f2567bcd6c73b72ad47c33da222201b0377e7677b996698774de8adf3eff551926393785323ecf46cb59d72eb0e5b05aa0 WHIRLPOOL b829f34c0729efea408624241d0b2209de549a29d0581d3b4338f1798aa9e9449b32fc27755e33849e7236f53e3da00c4e6f2e2fc8e46e8193b4c1dec7d49386
diff --git a/dev-ruby/thor/thor-0.19.4.ebuild b/dev-ruby/thor/thor-0.19.4.ebuild
new file mode 100644
index 000000000000..3a8b6aaf3850
--- /dev/null
+++ b/dev-ruby/thor/thor-0.19.4.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+RUBY_FAKEGEM_BINWRAP="thor"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A scripting framework that replaces rake and sake"
+HOMEPAGE="http://whatisthor.com/"
+
+SRC_URI="https://github.com/erikhuda/${PN}/archive/v${PV}.tar.gz -> ${PN}-git-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~amd64-linux"
+IUSE="doc"
+
+USE_RUBY="ruby21 ruby22 ruby23" ruby_add_bdepend "
+ test? (
+ dev-ruby/childlabor
+ dev-ruby/webmock:0
+ )"
+
+all_ruby_prepare() {
+ # Remove rspec default options (as we might not have the last
+ # rspec).
+ rm .rspec || die
+
+ # Remove Bundler
+ #rm Gemfile || die
+ sed -i -e '/[Bb]undler/d' Thorfile || die
+
+ # Remove mandatory coverage collection using simplecov which is not
+ # packaged.
+ sed -i -e '/require .simplecov/,/^ end/ s:^:#:' spec/helper.rb || die
+
+ # Avoid a spec that requires UTF-8 support, so LANG=C still works,
+ # bug 430402
+ sed -i -e '/uses maximum terminal width/,/end/ s:^:#:' spec/shell/basic_spec.rb || die
+}
+
+each_ruby_test() {
+ case ${RUBY} in
+ *ruby24)
+ einfo "Skipping tests due to circular dependencies"
+ ;;
+ *)
+ RSPEC_VERSION=3 ruby-ng_rspec spec || die
+ ;;
+ esac
+}