summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-07-17 09:07:00 +0200
committerHans de Graaff <graaff@gentoo.org>2019-07-17 09:07:00 +0200
commit6ecd5fe1b95f1045aab6e42490db8c9b5d180deb (patch)
treed8187d796589c6a367c014f19991d1bfd10b5cba /dev-ruby/thor
parentdev-ruby/treetop: add ruby25 ruby26 (diff)
downloadgentoo-6ecd5fe1b95f1045aab6e42490db8c9b5d180deb.tar.gz
gentoo-6ecd5fe1b95f1045aab6e42490db8c9b5d180deb.tar.bz2
gentoo-6ecd5fe1b95f1045aab6e42490db8c9b5d180deb.zip
dev-ruby/thor: cleanup
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
Diffstat (limited to 'dev-ruby/thor')
-rw-r--r--dev-ruby/thor/Manifest1
-rw-r--r--dev-ruby/thor/thor-0.19.4.ebuild41
2 files changed, 0 insertions, 42 deletions
diff --git a/dev-ruby/thor/Manifest b/dev-ruby/thor/Manifest
index 0964f02e51a7..2ca05151556e 100644
--- a/dev-ruby/thor/Manifest
+++ b/dev-ruby/thor/Manifest
@@ -1,2 +1 @@
-DIST thor-git-0.19.4.tgz 88733 BLAKE2B 8be54310cc4bf4a0308e6b103832831b89285003bb22a679986cd02636aaee57a25aa606f3e99bf532961a4e1d3625c46bfdb874a09f66cab85a21e5f7ed22d6 SHA512 a5cc52b23806e6104b12f924324960f2567bcd6c73b72ad47c33da222201b0377e7677b996698774de8adf3eff551926393785323ecf46cb59d72eb0e5b05aa0
DIST thor-git-0.20.3.tgz 94786 BLAKE2B a27ef27d9d375c1f5ab1b065f6ee5b635dab3b43cac7915ae24771e7a9e24189b8c3df8936bf6ad333f0660e4e36ff73372746afc227972f1745dc993b90c85f SHA512 368cedd9584fcdecf8f5feb9b727aa283b37747e8200f8629aaa762f8e3a59dafe6ee1e7c60ef2b43b2a16b319842b10d0f3face12ba8dded4b6211640db7f44
diff --git a/dev-ruby/thor/thor-0.19.4.ebuild b/dev-ruby/thor/thor-0.19.4.ebuild
deleted file mode 100644
index f548e71b984e..000000000000
--- a/dev-ruby/thor/thor-0.19.4.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby22 ruby23 ruby24"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_RECIPE_TEST="none"
-RUBY_FAKEGEM_DOCDIR="rdoc"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-RUBY_FAKEGEM_BINWRAP="thor"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A scripting framework that replaces rake and sake"
-HOMEPAGE="http://whatisthor.com/"
-
-SRC_URI="https://github.com/erikhuda/${PN}/archive/v${PV}.tar.gz -> ${PN}-git-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux"
-IUSE="doc"
-
-all_ruby_prepare() {
- # Remove rspec default options (as we might not have the last
- # rspec).
- rm .rspec || die
-
- # Remove Bundler
- #rm Gemfile || die
- sed -i -e '/[Bb]undler/d' Thorfile || die
-
- # Remove mandatory coverage collection using simplecov which is not
- # packaged.
- sed -i -e '/require .simplecov/,/^ end/ s:^:#:' spec/helper.rb || die
-
- # Avoid a spec that requires UTF-8 support, so LANG=C still works,
- # bug 430402
- sed -i -e '/uses maximum terminal width/,/end/ s:^:#:' spec/shell/basic_spec.rb || die
-}