summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-04-11 19:14:56 +0200
committerHans de Graaff <graaff@gentoo.org>2019-04-11 19:46:12 +0200
commit741ebd72ee23a838163d261272e5ded703966d07 (patch)
tree437e673805b3a943a9d090ec2b2a5313cd90ad9c /dev-ruby/thor
parentdev-ruby/typhoeus: cleanup (diff)
downloadgentoo-741ebd72ee23a838163d261272e5ded703966d07.tar.gz
gentoo-741ebd72ee23a838163d261272e5ded703966d07.tar.bz2
gentoo-741ebd72ee23a838163d261272e5ded703966d07.zip
dev-ruby/thor: cleanup
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'dev-ruby/thor')
-rw-r--r--dev-ruby/thor/Manifest1
-rw-r--r--dev-ruby/thor/thor-0.20.0.ebuild58
2 files changed, 0 insertions, 59 deletions
diff --git a/dev-ruby/thor/Manifest b/dev-ruby/thor/Manifest
index 5c65cf00dff4..0964f02e51a7 100644
--- a/dev-ruby/thor/Manifest
+++ b/dev-ruby/thor/Manifest
@@ -1,3 +1,2 @@
DIST thor-git-0.19.4.tgz 88733 BLAKE2B 8be54310cc4bf4a0308e6b103832831b89285003bb22a679986cd02636aaee57a25aa606f3e99bf532961a4e1d3625c46bfdb874a09f66cab85a21e5f7ed22d6 SHA512 a5cc52b23806e6104b12f924324960f2567bcd6c73b72ad47c33da222201b0377e7677b996698774de8adf3eff551926393785323ecf46cb59d72eb0e5b05aa0
-DIST thor-git-0.20.0.tgz 91758 BLAKE2B 86e4079a86a9c65852e710e40e49e915afe5522512f061ecc62aed48acc08a5397cc82d45cff7c4b1dd549ec57d8699b9afe7c391ac9ab838d1ba9100f1f058a SHA512 aa5344c94cad7c33dd0582409dbcf9bd109bf97b37131357a4cc8a66317acf8781460e8fe5532b301a74521010be59bb34ac1c68bc01ad3140bfe73fedc2a451
DIST thor-git-0.20.3.tgz 94786 BLAKE2B a27ef27d9d375c1f5ab1b065f6ee5b635dab3b43cac7915ae24771e7a9e24189b8c3df8936bf6ad333f0660e4e36ff73372746afc227972f1745dc993b90c85f SHA512 368cedd9584fcdecf8f5feb9b727aa283b37747e8200f8629aaa762f8e3a59dafe6ee1e7c60ef2b43b2a16b319842b10d0f3face12ba8dded4b6211640db7f44
diff --git a/dev-ruby/thor/thor-0.20.0.ebuild b/dev-ruby/thor/thor-0.20.0.ebuild
deleted file mode 100644
index 60e9b5f02184..000000000000
--- a/dev-ruby/thor/thor-0.20.0.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby22 ruby23 ruby24 ruby25"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-RUBY_FAKEGEM_DOCDIR="rdoc"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-RUBY_FAKEGEM_BINWRAP="thor"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A scripting framework that replaces rake and sake"
-HOMEPAGE="http://whatisthor.com/"
-
-SRC_URI="https://github.com/erikhuda/${PN}/archive/v${PV}.tar.gz -> ${PN}-git-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux"
-IUSE="doc"
-
-USE_RUBY="ruby22 ruby23 ruby24" ruby_add_bdepend "
- test? (
- dev-ruby/childlabor
- dev-ruby/webmock
- )"
-
-all_ruby_prepare() {
- # Remove rspec default options (as we might not have the last
- # rspec).
- rm .rspec || die
-
- # Remove Bundler
- #rm Gemfile || die
- sed -i -e '/[Bb]undler/d' Thorfile || die
-
- # Remove mandatory coverage collection using simplecov which is not
- # packaged.
- sed -i -e '/require .simplecov/,/^ end/ s:^:#:' spec/helper.rb || die
-
- # Avoid a spec that requires UTF-8 support, so LANG=C still works,
- # bug 430402
- sed -i -e '/uses maximum terminal width/,/end/ s:^:#:' spec/shell/basic_spec.rb || die
-}
-
-each_ruby_test() {
- case ${RUBY} in
- *ruby25)
- einfo "Skipping tests due to circular dependencies"
- ;;
- *)
- RSPEC_VERSION=3 ruby-ng_rspec spec || die
- ;;
- esac
-}