summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-08-30 06:48:47 +0200
committerHans de Graaff <graaff@gentoo.org>2018-08-30 06:49:44 +0200
commit8fbe6d23ca66365d936757c8fc3385f86c4e7b0f (patch)
treeb0dc9f25d3b50a66b7790d1249ab28f0b2e062c4 /dev-ruby/thread_order/thread_order-1.1.1.ebuild
parentdev-ruby/acts_as_list: add 0.9.16 (diff)
downloadgentoo-8fbe6d23ca66365d936757c8fc3385f86c4e7b0f.tar.gz
gentoo-8fbe6d23ca66365d936757c8fc3385f86c4e7b0f.tar.bz2
gentoo-8fbe6d23ca66365d936757c8fc3385f86c4e7b0f.zip
dev-ruby/thread_order: add 1.1.1
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-ruby/thread_order/thread_order-1.1.1.ebuild')
-rw-r--r--dev-ruby/thread_order/thread_order-1.1.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/thread_order/thread_order-1.1.1.ebuild b/dev-ruby/thread_order/thread_order-1.1.1.ebuild
new file mode 100644
index 000000000000..2508265e0f6f
--- /dev/null
+++ b/dev-ruby/thread_order/thread_order-1.1.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="Readme.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Test helper for ordering threaded code"
+HOMEPAGE="https://github.com/JoshCheek/thread_order"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+all_ruby_prepare() {
+ # Avoid failing spec that already has exceptions for some ruby
+ # implementations and is not essential.
+ sed -i -e '/depending on the stdlib/,/^ end/ s:^:#:' \
+ spec/thread_order_spec.rb || die
+}