summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-02-18 16:47:16 +0100
committerHans de Graaff <graaff@gentoo.org>2024-02-18 16:49:01 +0100
commit6bb52bbe4fcbc2f9d1e56dd7c89ad13bce879b61 (patch)
tree053609a561716338c183fc9dd56493100bf25059 /dev-ruby/thread_safe
parentnet-misc/sunshine: On second thoughts, unbundle nv-codec-headers (diff)
downloadgentoo-6bb52bbe4fcbc2f9d1e56dd7c89ad13bce879b61.tar.gz
gentoo-6bb52bbe4fcbc2f9d1e56dd7c89ad13bce879b61.tar.bz2
gentoo-6bb52bbe4fcbc2f9d1e56dd7c89ad13bce879b61.zip
dev-ruby/thread_safe: drop atomic test dependency
This dependency is optional and thread_safe works fine without it. Removing it will allow us to mask atomic for removal. Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/thread_safe')
-rw-r--r--dev-ruby/thread_safe/thread_safe-0.3.6-r3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/thread_safe/thread_safe-0.3.6-r3.ebuild b/dev-ruby/thread_safe/thread_safe-0.3.6-r3.ebuild
new file mode 100644
index 000000000000..5c1fc6d1c363
--- /dev/null
+++ b/dev-ruby/thread_safe/thread_safe-0.3.6-r3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A collection of thread-safe versions of common core Ruby classes"
+HOMEPAGE="https://github.com/ruby-concurrency/thread_safe"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="test"
+
+each_ruby_prepare() {
+ sed -i -e "/[Bb]undler/d" Rakefile || die
+ sed -i -e '/coveralls/I s:^:#:' \
+ -e '/simplecov/ s:^:#:' \
+ -e '/SimpleCov/,/^end/ s:^:#:' spec/spec_helper.rb || die
+}
+
+each_ruby_test() {
+ einfo "The test suite may take up to 10 minutes to run without apparent feedback"
+ each_fakegem_test
+}