summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-01-08 07:33:44 +0100
committerHans de Graaff <graaff@gentoo.org>2016-01-08 07:33:44 +0100
commitd62c6bfb24d5ac1a11224fad0e5983b1ad94f119 (patch)
tree3197facb390540f06dde75e6f971f801c0df91d6 /dev-ruby/tilt
parentdev-ruby/ruby-net-ldap: add 0.13.0 (diff)
downloadgentoo-d62c6bfb24d5ac1a11224fad0e5983b1ad94f119.tar.gz
gentoo-d62c6bfb24d5ac1a11224fad0e5983b1ad94f119.tar.bz2
gentoo-d62c6bfb24d5ac1a11224fad0e5983b1ad94f119.zip
dev-ruby/tilt: add 2.0.2
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-ruby/tilt')
-rw-r--r--dev-ruby/tilt/Manifest1
-rw-r--r--dev-ruby/tilt/tilt-2.0.2.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-ruby/tilt/Manifest b/dev-ruby/tilt/Manifest
index 84944e8c609f..180795368de8 100644
--- a/dev-ruby/tilt/Manifest
+++ b/dev-ruby/tilt/Manifest
@@ -1,2 +1,3 @@
DIST tilt-1.4.1.gem 42496 SHA256 39820562c4f5db45fe18de87ccc30a0e77a998bf5334b1d8c10a2f7dbc1f5903 SHA512 10fec263596d0e18a7a1440a7edfa08a161526cc46cc70427bc251951c447c40b4a4e8675e9162a9ed288879682b4aceeeb35b48cf3f4925921025194543363f WHIRLPOOL 5d70949358b97e867cdec160bd3c3726dabfec94bfeadc3a12f17463d378779d8502dda6458c7deb92bd3d9def91e306077ef806a7f75bd6c892554739ce46e9
DIST tilt-2.0.1.gem 44544 SHA256 73dc6e2cd2fe4251cb7d15c92d0e66c884f17d0be580500d00cb426eb29881e1 SHA512 9451b2387c7c2535c9c78ae07dc0893f675e921d845f8eb5bc24c13a1e726888baba0d813195a81014370b640b290fab2e1b47871b6b2ab1e3eddb10c71217df WHIRLPOOL 92773f66291c193e912f810b8ad3da827782e744b19e2ef0ece7db262ff8a66324e9e08362f3b37ce14d125a196e743f1e264ef739bfeeaecd37c1a29c15c7e6
+DIST tilt-2.0.2.gem 48640 SHA256 04c91dcf7533576196e3ea2ba22514f37811ab7419bab6c71877e2e63a206d52 SHA512 93540d673f1c0e841be43e54e85451482f6ea8f967d14bce46c997be69a9ff16684aa5966c91cfd8d590cc32ef590974151183839ec315d46df5d398fd016832 WHIRLPOOL 051c29727ce157bf73d1c276c500471a48bde23a8a0ce516ad75e88a99b738e7c1a0283070db2c127922582e4f674e8591c69d36821744d5d09a3d0f9d0bd03f
diff --git a/dev-ruby/tilt/tilt-2.0.2.ebuild b/dev-ruby/tilt/tilt-2.0.2.ebuild
new file mode 100644
index 000000000000..2d5f93bff535
--- /dev/null
+++ b/dev-ruby/tilt/tilt-2.0.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md docs/TEMPLATES.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A thin interface over a Ruby template engines to make their usage as generic as possible"
+HOMEPAGE="https://github.com/rtomayko/tilt"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# Block on some of the potential test dependencies. These dependencies
+# are optional for the test suite, and we don't want to depend on all of
+# them to faciliate keywording and stabling.
+ruby_add_bdepend "test? (
+ dev-ruby/bluecloth
+ dev-ruby/coffee-script
+ dev-ruby/erubis
+ dev-ruby/nokogiri
+ !!<dev-ruby/maruku-0.7.2 )"
+
+# Most dependencies are optional: skip haml and radius for ruby20 and ruby21
+# because haml depends on rails.
+USE_RUBY="ruby20" ruby_add_bdepend "test? ( dev-ruby/haml )"
+USE_RUBY="ruby20 ruby21" ruby_add_bdepend "test? ( dev-ruby/radius )"
+
+ruby_add_rdepend ">=dev-ruby/builder-2.0.0:*
+ !!<dev-ruby/tilt-1.4.1-r2:0"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -e '/bundler/I s:^:#:' -i Rakefile test/test_helper.rb || die
+
+ # Avoid tests with minor syntax differences since this happens all
+ # the time when details in the dependencies change.
+ sed -e '/test_smarty_pants_true/,/^ end/ s:^:#:' -i test/tilt_markdown_test.rb || die
+ sed -e '/smartypants when :smart is set/,/^ end/ s:^:#:' -i test/tilt_rdiscounttemplate_test.rb || die
+ sed -i -e '/docbook templates/,/^ end/ s:^:#:' test/tilt_asciidoctor_test.rb || die
+}