summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-06-23 04:55:16 +0200
committerHans de Graaff <graaff@gentoo.org>2017-06-23 04:55:16 +0200
commit2bba10bb5ba609391c3238e99e5e126e2d04753e (patch)
treeb90d14bd3a9b6622d82e49c4c812fec76bd94935 /dev-ruby/timecop/timecop-0.9.0.ebuild
parentdev-python/pip: don't use epatch (diff)
downloadgentoo-2bba10bb5ba609391c3238e99e5e126e2d04753e.tar.gz
gentoo-2bba10bb5ba609391c3238e99e5e126e2d04753e.tar.bz2
gentoo-2bba10bb5ba609391c3238e99e5e126e2d04753e.zip
dev-ruby/timecop: add 0.9.0
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'dev-ruby/timecop/timecop-0.9.0.ebuild')
-rw-r--r--dev-ruby/timecop/timecop-0.9.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ruby/timecop/timecop-0.9.0.ebuild b/dev-ruby/timecop/timecop-0.9.0.ebuild
new file mode 100644
index 000000000000..b7796fa34318
--- /dev/null
+++ b/dev-ruby/timecop/timecop-0.9.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+
+RUBY_FAKEGEM_TASK_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A gem providing 'time travel' and 'time freezing' capabilities"
+HOMEPAGE="https://github.com/jtrupiano/timecop"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+# Missing testdep activesupport
+ruby_add_bdepend "test? ( dev-ruby/mocha )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' -e '/History.rdoc/d' Rakefile test/test_helper.rb || die
+ sed -i -e '/rubygems/ a\gem "test-unit"' \
+ -e '/minitest\/rg/ s:^:#:' test/test_helper.rb || die
+ # FIXME after activesupport gained ruby22 support
+ rm test/time_stack_item_test.rb || die
+}
+
+each_ruby_test() {
+ for f in test/*_test.rb ; do
+ ${RUBY} -Ilib $f || die
+ done
+}