summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <junghans@gentoo.org>2017-03-07 16:31:24 -0700
committerChristoph Junghans <junghans@gentoo.org>2017-03-07 16:31:45 -0700
commit24ef3d03ce0926e22d56daaed78218744dc3d190 (patch)
tree35722b1deadf6e0002cad6ec8e8defd176b352d2 /dev-ruby/travis/travis-1.8.8.ebuild
parentdev-lang/crystal: bump up to 0.21.1 (diff)
downloadgentoo-24ef3d03ce0926e22d56daaed78218744dc3d190.tar.gz
gentoo-24ef3d03ce0926e22d56daaed78218744dc3d190.tar.bz2
gentoo-24ef3d03ce0926e22d56daaed78218744dc3d190.zip
dev-ruby/travis: version bump
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ruby/travis/travis-1.8.8.ebuild')
-rw-r--r--dev-ruby/travis/travis-1.8.8.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/dev-ruby/travis/travis-1.8.8.ebuild b/dev-ruby/travis/travis-1.8.8.ebuild
new file mode 100644
index 000000000000..55b86cf0dce7
--- /dev/null
+++ b/dev-ruby/travis/travis-1.8.8.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby21 ruby22"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_EXTRAINSTALL="assets"
+
+inherit bash-completion-r1 ruby-fakegem
+
+DESCRIPTION="Travis CI Client (CLI and Ruby library)"
+HOMEPAGE="https://github.com/travis-ci/travis.rb"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+#RESTRICT="test"
+
+DEPEND+="test? ( dev-vcs/git )"
+RDEPEND+="dev-vcs/git"
+
+ruby_add_bdepend "
+ test? ( >dev-ruby/rack-test-0.6 )
+ >dev-ruby/sinatra-1.3
+"
+
+ruby_add_rdepend "
+ dev-ruby/backports
+ >dev-ruby/faraday-0.9
+ >=dev-ruby/faraday_middleware-0.9.1
+ >dev-ruby/gh-0.13
+ >dev-ruby/highline-1.6
+ >dev-ruby/launchy-2.1
+ >dev-ruby/pusher-client-0.4
+ dev-ruby/typhoeus:0
+"
+
+all_ruby_prepare() {
+ if use test ; then
+ git init --quiet . || die
+ git remote add origin "${HOMEPAGE}" || die
+ touch .travis.yml || die
+ fi
+
+ # Remove failing spec where cause is not fully clear.
+ # May be related to highline compatibility issues.
+ rm spec/cli/login_spec.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ newbashcomp "assets/travis.sh" "travis"
+}