summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-06-15 08:05:33 +0200
committerHans de Graaff <graaff@gentoo.org>2019-06-15 11:55:36 +0200
commit3ab8a8a2fddf5c80edbbd900ec4d7296d2196cf2 (patch)
treef6a3bb1ad66ad298b4e5a20880e60fd3930f1d31 /dev-ruby/tty-command
parentdev-ruby/tty-color: add 0.4.3 (diff)
downloadgentoo-3ab8a8a2fddf5c80edbbd900ec4d7296d2196cf2.tar.gz
gentoo-3ab8a8a2fddf5c80edbbd900ec4d7296d2196cf2.tar.bz2
gentoo-3ab8a8a2fddf5c80edbbd900ec4d7296d2196cf2.zip
dev-ruby/tty-command: initial import of 0.8.2
New dependency for www-apps/nanoc Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
Diffstat (limited to 'dev-ruby/tty-command')
-rw-r--r--dev-ruby/tty-command/Manifest1
-rw-r--r--dev-ruby/tty-command/metadata.xml11
-rw-r--r--dev-ruby/tty-command/tty-command-0.8.2.ebuild31
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-ruby/tty-command/Manifest b/dev-ruby/tty-command/Manifest
new file mode 100644
index 000000000000..b8f21fb31199
--- /dev/null
+++ b/dev-ruby/tty-command/Manifest
@@ -0,0 +1 @@
+DIST tty-command-0.8.2.tar.gz 30126 BLAKE2B 858b9c60380859bd984295e00638ba93416c62acbe4e5c1d0e33b411862d729c129f00dda236f4ca9943962859a35c9fe1fa2431327fb2e3170366412f8d83e3 SHA512 151af5fe0cf241b4e8004560d04fe967d8fe1d24cf311d64c4fab46d1c11b1fe27849f3925f13d3a73b7b86a55aabacd3e4bbffa9a96c34669c93b29756fe88e
diff --git a/dev-ruby/tty-command/metadata.xml b/dev-ruby/tty-command/metadata.xml
new file mode 100644
index 000000000000..9be0b27e3e08
--- /dev/null
+++ b/dev-ruby/tty-command/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">piotrmurach/tty-command</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/tty-command/tty-command-0.8.2.ebuild b/dev-ruby/tty-command/tty-command-0.8.2.ebuild
new file mode 100644
index 000000000000..3bb1808e5d9c
--- /dev/null
+++ b/dev-ruby/tty-command/tty-command-0.8.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Terminal color capabilities detection"
+HOMEPAGE="https://github.com/piotrmurach/tty-command"
+SRC_URI="https://github.com/piotrmurach/tty-command/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "=dev-ruby/pastel-0.7*"
+
+all_ruby_prepare() {
+ echo '-rspec_helper' > .rspec || die
+}