summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-06-15 08:08:35 +0200
committerHans de Graaff <graaff@gentoo.org>2019-06-15 11:55:37 +0200
commitd1bcfc93707e4e96a0a37be3f3d498ebd1016347 (patch)
treee5ad0c92b2319290ac5ba0913b672d042021208d /dev-ruby/tty-platform
parentdev-ruby/tty-command: initial import of 0.8.2 (diff)
downloadgentoo-d1bcfc93707e4e96a0a37be3f3d498ebd1016347.tar.gz
gentoo-d1bcfc93707e4e96a0a37be3f3d498ebd1016347.tar.bz2
gentoo-d1bcfc93707e4e96a0a37be3f3d498ebd1016347.zip
dev-ruby/tty-platform: initial import of 0.2.0
New dependency for www-apps/nanoc Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
Diffstat (limited to 'dev-ruby/tty-platform')
-rw-r--r--dev-ruby/tty-platform/Manifest1
-rw-r--r--dev-ruby/tty-platform/metadata.xml11
-rw-r--r--dev-ruby/tty-platform/tty-platform-0.2.0.ebuild24
3 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/tty-platform/Manifest b/dev-ruby/tty-platform/Manifest
new file mode 100644
index 000000000000..9a4fb99a0a6f
--- /dev/null
+++ b/dev-ruby/tty-platform/Manifest
@@ -0,0 +1 @@
+DIST tty-platform-0.2.0.gem 10240 BLAKE2B 5a49c928cc6c7940bf5feb99a9433dd978a1d21e139f43f646f6a566111ef2e1b6bd4a971327275bd05aaa0394199c7489f00ac4883be9b1ff9bba3ad840dbfc SHA512 56f81c326e81f407246aa7363e4734f3d7e11b6b4abaa5d8f41e684124407df4866ecbc31aa4180703149659245e740d84aa2baee2192e21eccb9ed251db32ac
diff --git a/dev-ruby/tty-platform/metadata.xml b/dev-ruby/tty-platform/metadata.xml
new file mode 100644
index 000000000000..8254c548c088
--- /dev/null
+++ b/dev-ruby/tty-platform/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">piotrmurach/tty-platform</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/tty-platform/tty-platform-0.2.0.ebuild b/dev-ruby/tty-platform/tty-platform-0.2.0.ebuild
new file mode 100644
index 000000000000..e30b88aa6f9c
--- /dev/null
+++ b/dev-ruby/tty-platform/tty-platform-0.2.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Query methods for detecting different operating systems"
+HOMEPAGE="https://github.com/piotrmurach/tty-platform"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ echo '-rspec_helper' > .rspec || die
+}