summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/turbolinks
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/turbolinks')
-rw-r--r--dev-ruby/turbolinks/Manifest2
-rw-r--r--dev-ruby/turbolinks/metadata.xml8
-rw-r--r--dev-ruby/turbolinks/turbolinks-2.5.1.ebuild24
-rw-r--r--dev-ruby/turbolinks/turbolinks-2.5.3.ebuild24
4 files changed, 58 insertions, 0 deletions
diff --git a/dev-ruby/turbolinks/Manifest b/dev-ruby/turbolinks/Manifest
new file mode 100644
index 000000000000..9f12dfb49366
--- /dev/null
+++ b/dev-ruby/turbolinks/Manifest
@@ -0,0 +1,2 @@
+DIST turbolinks-2.5.1.gem 21504 SHA256 a5daa156152cea92b3b5b348ac16a0100c9039603b5f8ac77b89af489b3f7fc7 SHA512 2f2eed08ad96e10c8bd59c055c827104d1ad5c50919543dac3b3d90910fac86cc7a042cc4d54b010100bd7d51b309aab354d2bb5a4469dbbd20c232c22f35392 WHIRLPOOL 3ba840f11b49c6387a7e4cf6fbbe4ea5df1ed378392bc884409637a57170f7fc1d8172ed7dc06889a9291a8ba9b83bb9073153aacda883cbb8e4396954f00f14
+DIST turbolinks-2.5.3.gem 20992 SHA256 5606242743a4c9bb1ef49bc5bb88ebdc2dc1a0ac99a602c9a71defbd8be8b9b5 SHA512 3ac0bd52793ae60d57ab8936646157eccd3e83b112ff4456286caea61c195a855f6b3d0b474aa3f298515bda537545fb8c328254144a958ff9a7271183011d2e WHIRLPOOL 5656e2a76f289580ee795a2b6e66f1711720731302990a53eb174d79ae1244f5da0ab4ebccb8949c8ca2933b1ab89b09c058ceea5c3916cd3f4806dde9d412b6
diff --git a/dev-ruby/turbolinks/metadata.xml b/dev-ruby/turbolinks/metadata.xml
new file mode 100644
index 000000000000..1502f4fb2038
--- /dev/null
+++ b/dev-ruby/turbolinks/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">rails/turbolinks</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/turbolinks/turbolinks-2.5.1.ebuild b/dev-ruby/turbolinks/turbolinks-2.5.1.ebuild
new file mode 100644
index 000000000000..19a5e903bbdb
--- /dev/null
+++ b/dev-ruby/turbolinks/turbolinks-2.5.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+# The gem does not contain runnable tests.
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Makes following links in your web application faster"
+HOMEPAGE="https://github.com/rails/turbolinks"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+ruby_add_rdepend "dev-ruby/coffee-rails"
diff --git a/dev-ruby/turbolinks/turbolinks-2.5.3.ebuild b/dev-ruby/turbolinks/turbolinks-2.5.3.ebuild
new file mode 100644
index 000000000000..19a5e903bbdb
--- /dev/null
+++ b/dev-ruby/turbolinks/turbolinks-2.5.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+# The gem does not contain runnable tests.
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Makes following links in your web application faster"
+HOMEPAGE="https://github.com/rails/turbolinks"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+ruby_add_rdepend "dev-ruby/coffee-rails"