summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-07-14 11:52:04 +0200
committerHans de Graaff <graaff@gentoo.org>2023-07-15 07:59:46 +0200
commit63acdd4db74da57be671a5bb720ed993a16355ad (patch)
treeed81adda8f2c4137ced72e61dc2934293ac7b387 /dev-ruby/vlad
parentmedia-video/mpv: note new options in live (diff)
downloadgentoo-63acdd4db74da57be671a5bb720ed993a16355ad.tar.gz
gentoo-63acdd4db74da57be671a5bb720ed993a16355ad.tar.bz2
gentoo-63acdd4db74da57be671a5bb720ed993a16355ad.zip
dev-ruby/vlad: update EAPI 7 -> 8
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/vlad')
-rw-r--r--dev-ruby/vlad/vlad-2.7.1-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/vlad/vlad-2.7.1-r1.ebuild b/dev-ruby/vlad/vlad-2.7.1-r1.ebuild
new file mode 100644
index 000000000000..c96c268f71e7
--- /dev/null
+++ b/dev-ruby/vlad/vlad-2.7.1-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="considerations.txt History.txt README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Pragmatic application deployment automation, without mercy"
+HOMEPAGE="https://github.com/seattlerb/vlad"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_bdepend ">=dev-ruby/hoe-3.13
+ test? ( >=dev-ruby/minitest-5.7 )"
+ruby_add_rdepend ">=dev-ruby/rake-remote_task-2.3"
+
+all_ruby_prepare() {
+ # Keep Isolate from managing the dependencies.
+ sed -i -e '/isolate/ s:^:#:' -e '/rubyforge/ s:^:#:' Rakefile || die
+}