summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-01-09 09:52:55 +0100
committerHans de Graaff <graaff@gentoo.org>2019-01-09 10:12:06 +0100
commitb9ab127453d4ad7ff944f0573adbd9788af8b78c (patch)
tree6d2bf45b1eefaacee5ab848e7b256543db6698e8 /dev-ruby/zentest/zentest-4.11.2.ebuild
parentdev-ruby/openssl-ccm: add 1.2.2 (diff)
downloadgentoo-b9ab127453d4ad7ff944f0573adbd9788af8b78c.tar.gz
gentoo-b9ab127453d4ad7ff944f0573adbd9788af8b78c.tar.bz2
gentoo-b9ab127453d4ad7ff944f0573adbd9788af8b78c.zip
dev-ruby/zentest: add 4.11.2
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-ruby/zentest/zentest-4.11.2.ebuild')
-rw-r--r--dev-ruby/zentest/zentest-4.11.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/zentest/zentest-4.11.2.ebuild b/dev-ruby/zentest/zentest-4.11.2.ebuild
new file mode 100644
index 000000000000..73989549488a
--- /dev/null
+++ b/dev-ruby/zentest/zentest-4.11.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_NAME=ZenTest
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.txt History.txt example.txt example1.rb example2.rb example_dot_autotest.rb"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Testing tools: zentest, unit_diff, autotest, multiruby, and Test::Rails"
+HOMEPAGE="https://github.com/seattlerb/zentest"
+LICENSE="Ruby"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/hoe-2.10
+ dev-ruby/hoe-seattlerb
+ dev-ruby/minitest:5
+ )"