summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-09-27 06:10:29 +0200
committerHans de Graaff <graaff@gentoo.org>2018-09-27 06:10:29 +0200
commit20f45848d4ded1ec890285da28ac4056a1631ef1 (patch)
treee38f8b79327021467c99612c4f850b2170a57f9b /dev-ruby
parentdev-lang/nim: bump up to 0.19.0, bug #635032 (diff)
downloadgentoo-20f45848d4ded1ec890285da28ac4056a1631ef1.tar.gz
gentoo-20f45848d4ded1ec890285da28ac4056a1631ef1.tar.bz2
gentoo-20f45848d4ded1ec890285da28ac4056a1631ef1.zip
dev-ruby/rack-protection: add 2.0.4
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/rack-protection/Manifest1
-rw-r--r--dev-ruby/rack-protection/rack-protection-2.0.4.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/rack-protection/Manifest b/dev-ruby/rack-protection/Manifest
index 8a431e51644a..ec4d7f0853a7 100644
--- a/dev-ruby/rack-protection/Manifest
+++ b/dev-ruby/rack-protection/Manifest
@@ -1,3 +1,4 @@
DIST rack-protection-1.5.5.gem 18432 BLAKE2B abda1313e7e0d04299a689c55241cd92d0f5ed2048395ab79f09ba271100a8dc99fbf5f924e3b3cbe28f318090144539eb0174cc1813d371d9f37df31ab04315 SHA512 c4066a50771247fc89d4ddee44ff87e40a24bad95e914ed2f72cbf9c45152e67e51d2ccc7d1725ade637296a080b06f304157a1a024613a97595b144e03e2e70
DIST rack-protection-2.0.2.gem 16896 BLAKE2B b3ed6a399f93c359a305cef0893bb5056ac26e8d5f345761f497b5eb77aecc201cd388bc0fc021ed039f230bc2ca2348f7eec19aaaac3f2662500bd4c6496a93 SHA512 e74be8b079a1c436d80df2e6bf58dcaea089aceb58b8ec6c08d6ac78b5390bdb1b494d9155350dc7e2639e858209aac10757be54085a565b910e5e74ee882235
DIST rack-protection-2.0.3.gem 16896 BLAKE2B e33cfc8290cf108f986bd625623411f63812aa79bc5354041e3d541a244bdc6f2ba30ebfab77cb2fe15c8a53e21e11adc6a54ab90a687147759d1b14b5e0be73 SHA512 396d1b45783e0b6782b479b6ba77c2eb23c2a6a2b695a631b7a4b9ace661471325d4d321a40ba7c8090964e68b5dd8f9c92c4843464e6d6ff178aecf9996f338
+DIST rack-protection-2.0.4.gem 16896 BLAKE2B d20bd67bfcbb8ba34689cdc909c1f89305bc6a08c44b9cdde8a7d1615c86400572a24a060a9100c699791cd910e5bbf17106b8c921e1e6a21f814457a93dc2c1 SHA512 e934873e7e8e45c1fa0450b568f33e28db29b9c4bacb0a747218ca929e73706518c09ce131f749e89dc7af894dcfbd6fcabdf12324edbfbcfa532eb227f977a4
diff --git a/dev-ruby/rack-protection/rack-protection-2.0.4.ebuild b/dev-ruby/rack-protection/rack-protection-2.0.4.ebuild
new file mode 100644
index 000000000000..688357c23602
--- /dev/null
+++ b/dev-ruby/rack-protection/rack-protection-2.0.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25"
+
+# There are no specs in the gem and the source cannot be downloaded separately.
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem eapi7-ver
+
+DESCRIPTION="This gem protects against typical web attacks"
+HOMEPAGE="https://github.com/rkh/rack-protection"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/rack:*"
+
+# ruby_add_bdepend "test? ( dev-ruby/rack-test )"