summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-02-18 00:18:14 +0100
committerManuel Rüger <mrueg@gentoo.org>2016-02-18 00:22:39 +0100
commit2c75c294815d88f79a9dac8e5cbf1ecd33d1a98f (patch)
tree38d81200a23d101459469fd55966b047f88830f8 /dev-ruby
parentmedia-sound/lame: add frontend useflag to allow lib only build. (diff)
downloadgentoo-2c75c294815d88f79a9dac8e5cbf1ecd33d1a98f.tar.gz
gentoo-2c75c294815d88f79a9dac8e5cbf1ecd33d1a98f.tar.bz2
gentoo-2c75c294815d88f79a9dac8e5cbf1ecd33d1a98f.zip
dev-ruby/classifier-reborn: Version bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/classifier-reborn/Manifest1
-rw-r--r--dev-ruby/classifier-reborn/classifier-reborn-2.0.4.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/classifier-reborn/Manifest b/dev-ruby/classifier-reborn/Manifest
index 9e13d5d0eeb6..c0c467b4a94e 100644
--- a/dev-ruby/classifier-reborn/Manifest
+++ b/dev-ruby/classifier-reborn/Manifest
@@ -1 +1,2 @@
DIST classifier-reborn-2.0.3.tar.gz 22888 SHA256 3cee84bd7bee0b6d64d94d370736eda7283a933afcc8e5b0a93af88e83937213 SHA512 37e6c078de65ac7851acc9e5ea3ffbad2dfde1923bf765b6cd936457cdf52d3738e35b84d1ef94e1b5af396e1821f09749090d29fdfaf121f0a0ac50ec9b1418 WHIRLPOOL d5ae8072aaf977404bc389473ce9ce8071c70cc10f886232fd292afa39a879030e6e1ee310fa60d61e36048074da9a8729eeba179cd92798bef1924604071d74
+DIST classifier-reborn-2.0.4.tar.gz 40653 SHA256 cd6d283a9f3e7aaffe7fe55d30d8f45ea6ba91027931b6c0c63bad007c9de53c SHA512 f89a075b61c1f36894cc57cba3943174c4414512e6f89dd2fa854126e38132239312f2b3464ffbd9b531d8f2987658fafa9cd8fe29d5f7ad8146984436deddd5 WHIRLPOOL 4f1a6c95fa08f4b3eb38078f441801657fdfa91d22e312fc36a46741f30365388b585fc85fca1693752be567ae3e213d82a522718af649d3af6efe8eecbf6c6f
diff --git a/dev-ruby/classifier-reborn/classifier-reborn-2.0.4.ebuild b/dev-ruby/classifier-reborn/classifier-reborn-2.0.4.ebuild
new file mode 100644
index 000000000000..a02a984b4e4e
--- /dev/null
+++ b/dev-ruby/classifier-reborn/classifier-reborn-2.0.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Module to allow Bayesian and other types of classifications"
+HOMEPAGE="https://github.com/jekyll/classifier-reborn"
+SRC_URI="https://github.com/jekyll/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="gsl test"
+
+ruby_add_rdepend ">=dev-ruby/fast-stemmer-1.0.0
+ !!dev-ruby/classifier
+ gsl? ( dev-ruby/rb-gsl )"
+
+all_ruby_prepare() {
+ sed -i -e "/[Bb]undler/d" Rakefile || die
+ if use !gsl; then
+ sed -e 's/$GSL = true/$GSL = false/'\
+ -e 's/vector_serialize/vector/'\
+ -i lib/${PN}/lsi.rb || die
+ fi
+ # Comment out broken test
+ sed -i -e "/assert 'Normal',/s/^/#/" test/bayes/bayesian_test.rb || die
+}