summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-09-13 08:53:51 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2021-09-13 08:55:07 -0500
commit37a789ba443707a8b636bc9a00181bc2f848b269 (patch)
tree1972193f2031d9d06063da6c230e3b1cee4a5ec4 /dev-ruby
parentdev-libs/leatherman: 1.12.5 clean up (diff)
downloadgentoo-37a789ba443707a8b636bc9a00181bc2f848b269.tar.gz
gentoo-37a789ba443707a8b636bc9a00181bc2f848b269.tar.bz2
gentoo-37a789ba443707a8b636bc9a00181bc2f848b269.zip
dev-ruby/facter: 3.14.18 cleanup
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/facter/Manifest1
-rw-r--r--dev-ruby/facter/facter-3.14.18.ebuild99
2 files changed, 0 insertions, 100 deletions
diff --git a/dev-ruby/facter/Manifest b/dev-ruby/facter/Manifest
index 9a63f38ec68a..ed12319a3e45 100644
--- a/dev-ruby/facter/Manifest
+++ b/dev-ruby/facter/Manifest
@@ -1,2 +1 @@
-DIST facter-3.14.18.tar.gz 409243 BLAKE2B 6d11498ecd82910ab82ec9674fbe7cf8d87f76f47dc6bf1a25c6138d498ad0c1d47ae5b2cb67fb092892e29279ff3263e2d025ff1317e4fb428105c943ee11e3 SHA512 537696324fd1ea653019fe3febdd168f40155d120bb0f9b899711c04f8252166731ab3530e2f03c01606e3549db3726e146b00781ac6ab5383f5ba2ce1e74d3f
DIST facter-3.14.19.tar.gz 409345 BLAKE2B f977bb36ec8042ac950babd19ed398b8bd4fece854304a8a7a5f6b7608c3ad6ba4999b9038e401d599883da5bad63304b502fef164d1988d68a8477f1ff302a1 SHA512 65efc0237edc8198165e8229ca5d64e165a36e58718a863e14df9de9b64d4c9fb911d084e23daa982473f0703077b2cb0a5de8c544161591a894d537312c30f0
diff --git a/dev-ruby/facter/facter-3.14.18.ebuild b/dev-ruby/facter/facter-3.14.18.ebuild
deleted file mode 100644
index b69eea0e499e..000000000000
--- a/dev-ruby/facter/facter-3.14.18.ebuild
+++ /dev/null
@@ -1,99 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
-
-# git-r3 goes after ruby-ng so that it overrides src_unpack properly
-inherit cmake eutils ruby-ng
-
-DESCRIPTION="A cross-platform ruby library for retrieving facts from operating systems"
-HOMEPAGE="http://www.puppetlabs.com/puppet/related-projects/facter/"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="test"
-if [[ ${PV} == 9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/puppetlabs/facter.git"
- EGIT_BRANCH="master"
-else
- [[ "${PV}" = *_rc* ]] || \
- KEYWORDS="amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc x86"
- SRC_URI="https://github.com/puppetlabs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-fi
-
-RESTRICT="!test? ( test )"
-
-ruby_add_bdepend "test? ( dev-ruby/rake dev-ruby/rspec:2 dev-ruby/mocha:0.14 )"
-
-RDEPEND="
- >=dev-cpp/cpp-hocon-0.2.1:=
- >=dev-libs/leatherman-1.0.0:=
- dev-libs/openssl:0=
- sys-apps/util-linux
- app-emulation/virt-what
- net-misc/curl
- dev-libs/boost:=[nls]
- >=dev-cpp/yaml-cpp-0.5.1
- !<app-admin/puppet-4.0.0"
-DEPEND="${RDEPEND}"
-
-# restore ${S} and override all phases exported by ruby-ng.eclass
-S="${WORKDIR}/${P}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.14.6-fix-static-libcpp-hocon.patch
- # be explicit about the version of rspec we test with
- "${FILESDIR}"/${PN}-3.14.8-explicit-rspec-2.patch
-)
-
-pkg_setup() {
- ruby-ng_pkg_setup
-}
-
-src_unpack() {
- default
-
- if [[ ${PV} == 9999 ]] ; then
- git-r3_src_unpack
- fi
-}
-
-src_prepare() {
- cmake_src_prepare
-}
-
-each_ruby_configure() {
- # hack for correct calculation of relative path from facter.rb to
- # libfacter.so
- my_ruby_sitelibdir=$(ruby_rbconfig_value 'sitelibdir')
-}
-
-src_configure() {
- ruby-ng_src_configure
-
- local mycmakeargs=(
- -DRUBY_LIB_INSTALL=${my_ruby_sitelibdir}
- -DBLKID_LIBRARYDIR="${EPREFIX}/$(get_libdir)"
- )
- cmake_src_configure
-}
-
-src_compile() {
- addpredict /proc/self/oom_score_adj
- cmake_src_compile
-}
-
-src_test() {
- cmake_src_test
-}
-
-each_ruby_install() {
- doruby "${BUILD_DIR}"/lib/facter.rb
-}
-
-src_install() {
- cmake_src_install
- ruby-ng_src_install
-}