summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-10-26 07:34:13 +0200
committerHans de Graaff <graaff@gentoo.org>2022-10-26 07:37:29 +0200
commit414f57b5b66473ba0b8b0b31da94dd1113880fcb (patch)
treea367ede3ab3499f5b333336853b53b06be1fb50d /dev-ruby
parentapp-text/qpdf: Stabilize 11.1.1 sparc, #878017 (diff)
downloadgentoo-414f57b5b66473ba0b8b0b31da94dd1113880fcb.tar.gz
gentoo-414f57b5b66473ba0b8b0b31da94dd1113880fcb.tar.bz2
gentoo-414f57b5b66473ba0b8b0b31da94dd1113880fcb.zip
dev-ruby/rdiscount: add 2.2.7
Closes: https://bugs.gentoo.org/871030 Closes: https://bugs.gentoo.org/874504 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/rdiscount/Manifest1
-rw-r--r--dev-ruby/rdiscount/rdiscount-2.2.7.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-ruby/rdiscount/Manifest b/dev-ruby/rdiscount/Manifest
index 3a292f56931a..7be77329b691 100644
--- a/dev-ruby/rdiscount/Manifest
+++ b/dev-ruby/rdiscount/Manifest
@@ -1 +1,2 @@
DIST rdiscount-2.2.0.2.gem 68096 BLAKE2B 91f67643103a46f3fc95f80191a85ce4c89bba6a83f7ed5542cc9ec1671628c6ac0543b206d87e2ffc469dc83139e5669ee7eb6713eba4116db19c071a15f402 SHA512 97a0fabb77238173f101298e4b4b6d4728b9e15cb7d3f14e7d1d978c44ab92dd89c2e02d0c15c0fa70a836eb54abca06b0027e26e5d87540bfe145c8527be3f7
+DIST rdiscount-2.2.7.gem 73728 BLAKE2B 0d63372c3e2f4fa1efeef12ec4f8a2b12b9fccd7506ac6609d7e8fea958e04cfa1cc96a484ffba17d643838705d52c1557604ca015fded282ec860a7fc2481a5 SHA512 4f60dc0dbfb6b8f95f80d577c872c2a747d7d15e9fc1f1bd3640f1207a5d262068754dcb6d7b53348fd69de20b85534a390aace35d1eff31112bfbe0f77569d1
diff --git a/dev-ruby/rdiscount/rdiscount-2.2.7.ebuild b/dev-ruby/rdiscount/rdiscount-2.2.7.ebuild
new file mode 100644
index 000000000000..1c7295f8c7ed
--- /dev/null
+++ b/dev-ruby/rdiscount/rdiscount-2.2.7.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_TASK_TEST="test:unit"
+
+RUBY_FAKEGEM_TASK_DOC="doc man"
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/extconf.rb)
+
+inherit ruby-fakegem
+
+DESCRIPTION="Implementation of John Gruber's Markdown"
+HOMEPAGE="https://github.com/rtomayko/rdiscount"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+IUSE=""
+
+all_ruby_prepare() {
+ # Hanna is broken for us and therefore we don't have it in portage.
+ sed -i -e 's/hanna/rdoc/' Rakefile || die
+
+ # Remove rule that will force a rebuild when running tests.
+ sed -i -e "/task 'test:unit' => \[:build\]/d" Rakefile || die
+
+ # Provide RUBY variable no longer provided by rake.
+ sed -i -e "1 iRUBY=${RUBY}" Rakefile || die
+
+ # Remove obsolete -rubygems argument, bug 775377
+ sed -i -e '/-rubygems/ s:^:#:' Rakefile || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/rdiscount.1
+}