summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-01-22 09:31:18 +0100
committerHans de Graaff <graaff@gentoo.org>2017-01-22 09:31:57 +0100
commit61bc17c2a230b2005c1e33d96942534dbcdef858 (patch)
tree5ef887f263d63d1d14e0fd76da84d773fce2783e /dev-ruby
parentmedia-sound/lilypond: Mask USE=guile2 (diff)
downloadgentoo-61bc17c2a230b2005c1e33d96942534dbcdef858.tar.gz
gentoo-61bc17c2a230b2005c1e33d96942534dbcdef858.tar.bz2
gentoo-61bc17c2a230b2005c1e33d96942534dbcdef858.zip
dev-ruby/ffi: use get_modname for prefix support
Thanks to amadio in https://github.com/gentoo/gentoo/pull/3563 Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/ffi/ffi-1.9.17.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-ruby/ffi/ffi-1.9.17.ebuild b/dev-ruby/ffi/ffi-1.9.17.ebuild
index fee39257e533..88c7fda56e31 100644
--- a/dev-ruby/ffi/ffi-1.9.17.ebuild
+++ b/dev-ruby/ffi/ffi-1.9.17.ebuild
@@ -12,7 +12,7 @@ RUBY_FAKEGEM_RECIPE_DOC="rdoc"
RUBY_FAKEGEM_DOCDIR="doc"
RUBY_FAKEGEM_EXTRADOC="README.md"
-inherit ruby-fakegem
+inherit multilib ruby-fakegem
DESCRIPTION="Ruby extension for programmatically loading dynamic libraries"
HOMEPAGE="https://wiki.github.com/ffi/ffi"
@@ -46,7 +46,7 @@ each_ruby_configure() {
each_ruby_compile() {
emake -Cext/ffi_c V=1
- cp ext/ffi_c/ffi_c.so lib/ || die
+ cp ext/ffi_c/ffi_c$(get_modname) lib/ || die
${RUBY} -S rake -f gen/Rakefile || die "types.conf generation failed"
}