summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-07-09 07:14:29 +0200
committerHans de Graaff <graaff@gentoo.org>2016-07-09 07:28:53 +0200
commit6708136424ff129e588ef9e9acb81a92d180f53b (patch)
tree902576859461edee15fa44b60d12960cf2ad4b06 /dev-ruby
parentdev-ruby/rspec-mocks: cleanup (diff)
downloadgentoo-6708136424ff129e588ef9e9acb81a92d180f53b.tar.gz
gentoo-6708136424ff129e588ef9e9acb81a92d180f53b.tar.bz2
gentoo-6708136424ff129e588ef9e9acb81a92d180f53b.zip
dev-ruby/rspec-expectations: cleanup
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/rspec-expectations/rspec-expectations-2.14.5.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/dev-ruby/rspec-expectations/rspec-expectations-2.14.5.ebuild b/dev-ruby/rspec-expectations/rspec-expectations-2.14.5.ebuild
deleted file mode 100644
index acf1eca2f101..000000000000
--- a/dev-ruby/rspec-expectations/rspec-expectations-2.14.5.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-USE_RUBY="ruby19 ruby20"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
-HOMEPAGE="http://rspec.rubyforge.org/"
-SRC_URI="https://github.com/rspec/${PN}/archive/v${PV}.tar.gz -> ${P}-git.tgz"
-
-LICENSE="MIT"
-SLOT="2"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-ruby_add_rdepend ">=dev-ruby/diff-lcs-1.1.3"
-
-ruby_add_bdepend "test? (
- >=dev-ruby/rspec-core-2.11.0:2
- >=dev-ruby/rspec-mocks-2.14.0:2
- )"
-
-all_ruby_prepare() {
- # Don't set up bundler: it doesn't understand our setup.
- sed -i -e '/[Bb]undler/d' Rakefile || die
-
- # Remove the Gemfile to avoid running through 'bundle exec'
- rm Gemfile || die
-
- # Remove .rspec options to avoid dependency on newer rspec when
- # bootstrapping.
- rm .rspec || die
-
- # fix up the gemspecs
- sed -i \
- -e '/git ls/d' \
- -e '/add_development_dependency/d' \
- "${RUBY_FAKEGEM_GEMSPEC}" || die
-}