summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-01-02 07:56:32 +0100
committerHans de Graaff <graaff@gentoo.org>2017-01-02 07:57:15 +0100
commitad5131be2d080bcb0e081f37673ca730ca5aac02 (patch)
tree70b111d7fd0096117063694df86c335cd9aef164 /dev-ruby
parentdev-ruby/sprockets: add 3.7.1 (diff)
downloadgentoo-ad5131be2d080bcb0e081f37673ca730ca5aac02.tar.gz
gentoo-ad5131be2d080bcb0e081f37673ca730ca5aac02.tar.bz2
gentoo-ad5131be2d080bcb0e081f37673ca730ca5aac02.zip
dev-ruby/hoe: add ruby24, fixing bug 603840
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/hoe/hoe-3.15.3-r1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-ruby/hoe/hoe-3.15.3-r1.ebuild b/dev-ruby/hoe/hoe-3.15.3-r1.ebuild
new file mode 100644
index 000000000000..69803a4c49cd
--- /dev/null
+++ b/dev-ruby/hoe/hoe-3.15.3-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.rdoc Manifest.txt README.rdoc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="template"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Hoe extends rake to provide full project automation"
+HOMEPAGE="https://www.zenspider.com/projects/hoe.html"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "test? ( >=dev-ruby/minitest-5.9:5 )"
+
+ruby_add_rdepend ">=dev-ruby/rake-0.8.7 <dev-ruby/rake-13.0"
+
+all_ruby_prepare() {
+ # Skip isolation
+ sed -i -e '/isolate/ s:^:#:' Rakefile || die
+
+ # Skip test depending on specifics of gem command name
+ sed -i -e '/test_nosudo/,/^ end/ s:^:#:' test/test_hoe.rb || die
+
+ # Gem.bin_wrapper does not work as expected on Gentoo.
+ sed -i -e 's/Gem.bin_wrapper//' lib/hoe/rcov.rb lib/hoe/publish.rb test/test_hoe_publish.rb || die
+
+ # Fix broken test by including the right plugin first
+ sed -i -e '/test_extensions/a Hoe.plugin :clean' test/test_hoe.rb || die
+
+ # Allow newer rake for compatibility with ruby24, bug 603840
+ sed -i -e '/dependency/ s/12.0/13.0/' Rakefile
+}
+
+all_ruby_compile() {
+ all_fakegem_compile
+
+ rdoc --title "seattlerb's hoe-3.5.1 Documentation" -o doc --main README.txt lib History.txt Manifest.txt README.txt || die
+}