summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-04-13 09:49:33 +0200
committerHans de Graaff <graaff@gentoo.org>2018-04-13 10:04:07 +0200
commitd3aff9feb7f87c93d11fdf9fd54fb3a0c7150797 (patch)
tree354f430209ca712a10051c506d7c1cec9ff5077b /dev-ruby
parentdev-libs/http-fetcher: clean up old. (diff)
downloadgentoo-d3aff9feb7f87c93d11fdf9fd54fb3a0c7150797.tar.gz
gentoo-d3aff9feb7f87c93d11fdf9fd54fb3a0c7150797.tar.bz2
gentoo-d3aff9feb7f87c93d11fdf9fd54fb3a0c7150797.zip
dev-ruby/racc: cleanup
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/racc/Manifest1
-rw-r--r--dev-ruby/racc/racc-1.4.11.ebuild65
2 files changed, 0 insertions, 66 deletions
diff --git a/dev-ruby/racc/Manifest b/dev-ruby/racc/Manifest
index 24ba4d371188..046d2c037557 100644
--- a/dev-ruby/racc/Manifest
+++ b/dev-ruby/racc/Manifest
@@ -1,2 +1 @@
-DIST racc-1.4.11.gem 113664 BLAKE2B 4068da68e1579fb2034c454ef0d19e00d1f7e48eba9a1e1646eecd4e75410d9bdb2ab84a9f40b3446fc686014f87042d843cd7c4726acf24632b5f208e34ee9b SHA512 147c3c0ade40ec5544397a9dbf8579514d97145c2cc9f4e16508d41265c1b5cd6fc986c09367792592b5ab6b274e271eb7dded02ea9c398eadafb8addda4ef0c
DIST racc-1.4.14.gem 116224 BLAKE2B 67abd0e9bed46d7c589c62426943c8594d3b119328cd08576247727b11beb9e32ea45c54d0aadefc26691972fc40aad1b009c55bcd90a5b89aaf37e37a1097c1 SHA512 7401ad1722c92101c24f881226e44bd8b21033c7bae8b13cbf329f9b426c312ce61d14ce584b4f94d6863b77f30d6ebccf26f9fca2de724f8e0659f0e2d2173f
diff --git a/dev-ruby/racc/racc-1.4.11.ebuild b/dev-ruby/racc/racc-1.4.11.ebuild
deleted file mode 100644
index abde995f44b3..000000000000
--- a/dev-ruby/racc/racc-1.4.11.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-USE_RUBY="ruby20 ruby21 ruby22"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_TASK_DOC="docs"
-RUBY_FAKEGEM_EXTRADOC="README.rdoc README.ja.rdoc TODO ChangeLog"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="A LALR(1) parser generator for Ruby"
-HOMEPAGE="https://github.com/tenderlove/racc"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc test"
-
-ruby_add_bdepend "dev-ruby/rake
- test? ( >=dev-ruby/minitest-4.0:0 )"
-
-all_ruby_prepare() {
- sed -i -e 's|/tmp/out|${TMPDIR:-/tmp}/out|' test/helper.rb || die "tests fix failed"
-
- # Avoid depending on rake-compiler since we don't use it to compile
- # the extension.
- sed -i -e '/rake-compiler/ s:^:#:' -e '/extensiontask/ s:^:#:' Rakefile
- sed -i -e '/ExtensionTask/,/^ end/ s:^:#:' Rakefile
-
- # Avoid isolation since dependencies are not properly declared.
- sed -i -e 's/, :isolate//' Rakefile || die
-
- # Use a version of the minitest gem that works consistently accross
- # all ruby versions.
- sed -i -e '2i gem "minitest", "~>4.0"' test/helper.rb || die
-}
-
-each_ruby_prepare() {
- ${RUBY} -Cext/racc extconf.rb || die
-}
-
-each_ruby_compile() {
- emake V=1 -Cext/racc
- # Copy over the file here so that we don't have to do
- # special ruby install for JRuby and the other
- # implementations.
- cp -l ext/racc/cparse$(get_modname) lib/racc/cparse$(get_modname) || die
-}
-
-each_ruby_test() {
- ${RUBY} -Ilib:test:. -e 'Dir["test/test_*.rb"].each{|f| require f}' || die
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- dodoc -r rdoc
-
- docinto examples
- dodoc -r sample
-}