summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-07-14 08:26:44 +0200
committerHans de Graaff <graaff@gentoo.org>2017-07-14 08:30:47 +0200
commite077647dffc03ee8ae0fa9abb2c19591d743edb2 (patch)
tree0c406090b4844ff508738d6bf8183837705ef4e5 /dev-ruby
parentdev-ruby/asciimath: add ruby24 (diff)
downloadgentoo-e077647dffc03ee8ae0fa9abb2c19591d743edb2.tar.gz
gentoo-e077647dffc03ee8ae0fa9abb2c19591d743edb2.tar.bz2
gentoo-e077647dffc03ee8ae0fa9abb2c19591d743edb2.zip
dev-ruby/asciidoctor: add 1.5.6
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/asciidoctor/Manifest1
-rw-r--r--dev-ruby/asciidoctor/asciidoctor-1.5.6.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-ruby/asciidoctor/Manifest b/dev-ruby/asciidoctor/Manifest
index 99bc4c64db3b..b0fb3f987835 100644
--- a/dev-ruby/asciidoctor/Manifest
+++ b/dev-ruby/asciidoctor/Manifest
@@ -1 +1,2 @@
DIST asciidoctor-1.5.5.tar.gz 543437 SHA256 2da103a6b108ba31fced25c79d52318f41f349a8552917a11e910d194f95190b SHA512 6a95c2e48314a1f44d6398d83c490231baeb4ebea8d8c0e0ef361c884251fe054d48afceccadfb6c34947946920731e0194fc3e398b8dd8b8b320ea9d37f1f66 WHIRLPOOL 1772b12098b117200b36c5bf3fe9659b178ced7c9994fcc1332bc89c4b3dde1824feae70e3b9178569283c69c0345e37ac4394877feac4aa0ae32c103b91359e
+DIST asciidoctor-1.5.6.tar.gz 527048 SHA256 ceaadf42fd0b649b7090070d359fed071e9d190fc060532c9a7e442a6297e269 SHA512 a9ceb4d75173141d0997bd64b06a7fddfbe79da3dd3c63d9507ef6955c1bec2a1f51fbba06173fb878e22e13ae3945bf7acd7f4fad9b15e8ed689f84bc9f6e46 WHIRLPOOL d28a94ec30383f20cecc44de1274454c3f9f62c6a317916b08365956b25fae6fbc4a114e642cebd976841828fbf2fad7108e9bd46ad9a4abf651cf3f4f9a7ed6
diff --git a/dev-ruby/asciidoctor/asciidoctor-1.5.6.ebuild b/dev-ruby/asciidoctor/asciidoctor-1.5.6.ebuild
new file mode 100644
index 000000000000..8fd8e5005e3f
--- /dev/null
+++ b/dev-ruby/asciidoctor/asciidoctor-1.5.6.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_TASK_TEST="test features"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.adoc README.adoc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Processor for converting AsciiDoc into HTML 5, DocBook 4.5 and other formats"
+HOMEPAGE="https://github.com/asciidoctor/asciidoctor"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64"
+IUSE=""
+
+ruby_add_bdepend "test? (
+ dev-util/cucumber
+ dev-ruby/rspec-expectations:*
+ dev-ruby/asciimath
+ dev-ruby/coderay
+ dev-ruby/erubis
+ dev-ruby/haml
+ dev-ruby/nokogiri
+ dev-ruby/slim
+ dev-ruby/tilt )"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/asciidoctor.1
+}