summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2016-10-16 22:21:30 -0400
committerZero_Chaos <zerochaos@gentoo.org>2016-10-16 22:21:30 -0400
commite0c459f77d61ca2fe112b0ca568ba4bb6adadc62 (patch)
treed72f024f98e79d937fe5b439b68a063f012a09ad /dev-ruby
parentwww-apps/icingaweb2-module-graphite: add upstream patch, they are SLOW (diff)
downloadgentoo-e0c459f77d61ca2fe112b0ca568ba4bb6adadc62.tar.gz
gentoo-e0c459f77d61ca2fe112b0ca568ba4bb6adadc62.tar.bz2
gentoo-e0c459f77d61ca2fe112b0ca568ba4bb6adadc62.zip
dev-ruby/addressable: needed ruby23 support for 2.3* and tests pass
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/addressable/addressable-2.3.8-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ruby/addressable/addressable-2.3.8-r1.ebuild b/dev-ruby/addressable/addressable-2.3.8-r1.ebuild
new file mode 100644
index 000000000000..58217467b50c
--- /dev/null
+++ b/dev-ruby/addressable/addressable-2.3.8-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_TASK_DOC="doc:yard"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RAKE_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A replacement for the URI implementation that is part of Ruby's standard library"
+HOMEPAGE="https://rubygems.org/gems/addressable https://github.com/sporkmonger/addressable"
+
+LICENSE="Apache-2.0"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )"
+ruby_add_bdepend "test? ( dev-ruby/rspec-its )"
+
+all_ruby_prepare() {
+ # Remove spec-related tasks so that we don't need to require rspec
+ # just to build the documentation, bug 383611.
+ sed -i -e '/spectask/d' Rakefile || die
+ rm tasks/rspec.rake || die
+ sed -i -e '/[Cc]overalls/d' spec/spec_helper.rb || die
+
+ # Remove specs requiring network connectivity
+ rm spec/addressable/net_http_compat_spec.rb || die
+}