summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-10-07 09:07:49 +0200
committerHans de Graaff <graaff@gentoo.org>2022-10-08 08:26:34 +0200
commitf0b92e1ca4a50da98856532d749d116a8649994c (patch)
tree39848ed7bdae09bc24e1d4a6284e7503eaf60083 /dev-ruby
parentdev-util/ply: add 2.2.0 (diff)
downloadgentoo-f0b92e1ca4a50da98856532d749d116a8649994c.tar.gz
gentoo-f0b92e1ca4a50da98856532d749d116a8649994c.tar.bz2
gentoo-f0b92e1ca4a50da98856532d749d116a8649994c.zip
dev-ruby/x25519: add 1.0.10
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/x25519/Manifest1
-rw-r--r--dev-ruby/x25519/x25519-1.0.10.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-ruby/x25519/Manifest b/dev-ruby/x25519/Manifest
index e02da291b442..628a3b08b7e9 100644
--- a/dev-ruby/x25519/Manifest
+++ b/dev-ruby/x25519/Manifest
@@ -1 +1,2 @@
+DIST x25519-1.0.10.tar.gz 44353 BLAKE2B 5ad7a7b68af8bdc5e64692b9b650504df3d152c63c6044cea6978e42cef856dfbd3c0bc9261b014eab80a3bfcfaaf6c7a85675806aa9529e6978228ce2956497 SHA512 10a2baeff5be2eca31ae96893f08877ae351f6c7d30d0cc5d2a9b63ada74733ab30ed7dd709b26802d3f1a130aa513747a32c370d031fc95b136e3a699eb2987
DIST x25519-1.0.9.tar.gz 44042 BLAKE2B 65129fdfc0c40099487da3eacbd91436b625fd1224d58139a09d2ec571cb063f69767d468c89af512b0bef81912786b44b6923afaeb4a14f97a47034b702d848 SHA512 48349960b69f88177b772f431a1751ad190a9d71ebb01e0aced7dcc278a18c2e7cb1dbb621524950685b974f2f63d23039973accf067720ce1b74c5bb1eb4f77
diff --git a/dev-ruby/x25519/x25519-1.0.10.ebuild b/dev-ruby/x25519/x25519-1.0.10.ebuild
new file mode 100644
index 000000000000..9033f7551f12
--- /dev/null
+++ b/dev-ruby/x25519/x25519-1.0.10.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_GEMSPEC="x25519.gemspec"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/x25519_ref10/extconf.rb)
+
+inherit ruby-fakegem
+
+DESCRIPTION="Key exchange via the X25519 (Curve25519) Elliptic Curve Diffie-Hellman function"
+HOMEPAGE="https://github.com/crypto-rb/x25519"
+SRC_URI="https://github.com/crypto-rb/x25519/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#: ; /coverall/I s:^:#:' spec/spec_helper.rb || die
+
+ sed -i -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # The precomputed implementation only works on amd64
+ if use amd64 ; then
+ RUBY_FAKEGEM_EXTENSIONS+=(ext/x25519_precomputed/extconf.rb)
+ else
+ sed -i -e '/\(x25519_precomputed\|X25519::Provider::Precomputed\)/ s:^:#:' lib/x25519.rb || die
+ rm -f spec/x25519/provider/precomputed_spec.rb || die
+ fi
+}