summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-09-15 07:32:33 +0200
committerHans de Graaff <graaff@gentoo.org>2020-09-15 07:32:33 +0200
commitf0c71b18c8b7b7c8bb59412454742b0e30065984 (patch)
tree498b3de1c851112e16ef52861d5505563b1ea5ca /dev-ruby
parentdev-ruby/gh: cleanup (diff)
downloadgentoo-f0c71b18c8b7b7c8bb59412454742b0e30065984.tar.gz
gentoo-f0c71b18c8b7b7c8bb59412454742b0e30065984.tar.bz2
gentoo-f0c71b18c8b7b7c8bb59412454742b0e30065984.zip
dev-ruby/GeoRuby: add ruby27
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/GeoRuby/GeoRuby-2.5.2-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/GeoRuby/GeoRuby-2.5.2-r1.ebuild b/dev-ruby/GeoRuby/GeoRuby-2.5.2-r1.ebuild
new file mode 100644
index 000000000000..8ff0ed900863
--- /dev/null
+++ b/dev-ruby/GeoRuby/GeoRuby-2.5.2-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_NAME="georuby"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby data holder for OGC Simple Features"
+HOMEPAGE="https://github.com/nofxx/georuby"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ # Avoid specs that are also failing in upstream Travis.
+ rm spec/geo_ruby/shp4r/shp_spec.rb || die
+}
+
+ruby_add_bdepend "test? ( dev-ruby/dbf
+ dev-ruby/nokogiri )"