summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2018-07-20 22:12:31 +0900
committerAkinori Hattori <hattya@gentoo.org>2018-07-20 22:23:33 +0900
commit1745b65b389b5a07d37cf4f65a00b9d9b2768107 (patch)
treed408533c6468a6c3a226cd11329120e9bfcedaf1 /dev-scheme/gauche/gauche-0.9.6-r1.ebuild
parentapp-text/dvisvgm: 2.4.2 (diff)
downloadgentoo-1745b65b389b5a07d37cf4f65a00b9d9b2768107.tar.gz
gentoo-1745b65b389b5a07d37cf4f65a00b9d9b2768107.tar.bz2
gentoo-1745b65b389b5a07d37cf4f65a00b9d9b2768107.zip
dev-scheme/gauche: specify system CA certificates path
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-scheme/gauche/gauche-0.9.6-r1.ebuild')
-rw-r--r--dev-scheme/gauche/gauche-0.9.6-r1.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/dev-scheme/gauche/gauche-0.9.6-r1.ebuild b/dev-scheme/gauche/gauche-0.9.6-r1.ebuild
new file mode 100644
index 000000000000..17f4e9bbdc4e
--- /dev/null
+++ b/dev-scheme/gauche/gauche-0.9.6-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit autotools
+
+MY_P="${P^g}"
+
+DESCRIPTION="A Unix system friendly Scheme Interpreter"
+HOMEPAGE="http://practical-scheme.net/gauche/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="ipv6 libressl mbedtls test"
+
+RDEPEND="sys-libs/gdbm
+ mbedtls? ( net-libs/mbedtls )"
+DEPEND="${RDEPEND}
+ test? (
+ !libressl? ( dev-libs/openssl:0 )
+ libressl? ( dev-libs/libressl:0 )
+ )"
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-gauche.m4.patch
+ "${FILESDIR}"/${PN}-ext-ldflags.patch
+ "${FILESDIR}"/${PN}-xz-info.patch
+ "${FILESDIR}"/${PN}-rfc.tls.patch
+)
+DOCS=( AUTHORS ChangeLog HACKING README )
+
+src_prepare() {
+ default
+ use ipv6 && sed -i "s/ -4//" ext/tls/ssltest-mod.scm
+
+ eautoconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable ipv6) \
+ --with-ca-bundle="${EPREFIX}"/etc/ssl/certs/ca-certificates.crt \
+ --with-libatomic-ops=no \
+ --with-slib="${EPREFIX}"/usr/share/slib \
+ --with-tls=axtls$(usex mbedtls ',mbedtls' '')
+}
+
+src_test() {
+ emake -j1 -s check
+}
+
+src_install() {
+ emake DESTDIR="${D}" install-pkg install-doc
+ einstalldocs
+}