summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-scheme/guile-cairo/files/1.3.90-various-fixes-20070601.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-scheme/guile-cairo/files/1.3.90-various-fixes-20070601.patch')
-rw-r--r--dev-scheme/guile-cairo/files/1.3.90-various-fixes-20070601.patch72
1 files changed, 72 insertions, 0 deletions
diff --git a/dev-scheme/guile-cairo/files/1.3.90-various-fixes-20070601.patch b/dev-scheme/guile-cairo/files/1.3.90-various-fixes-20070601.patch
new file mode 100644
index 000000000000..eb867ffe56df
--- /dev/null
+++ b/dev-scheme/guile-cairo/files/1.3.90-various-fixes-20070601.patch
@@ -0,0 +1,72 @@
+=== modified file 'ChangeLog'
+--- ChangeLog 2007-05-18 17:38:56 +0000
++++ ChangeLog 2007-05-20 22:36:42 +0000
+@@ -1,3 +1,15 @@
++2007-05-21 Andy Wingo <wingo@pobox.com>
++
++ * guile-cairo/guile-cairo-enum-types.h: Include <cairo-svg.h> if
++ we are wrapping cairo_svg_version_t.
++
++2007-05-20 Andy Wingo <wingo@pobox.com>
++
++ * guile-cairo/guile-cairo.c (scm_init_cairo): Add guard against
++ multiple instantiations.
++
++ * guile-cairo/guile-cairo.h: Include cairo.h header.
++
+ 2007-05-18 Andy Wingo <wingo@pobox.com>
+
+ * configure.ac: Change version to 1.3.90.
+
+=== modified file 'guile-cairo/guile-cairo-enum-types.h'
+--- guile-cairo/guile-cairo-enum-types.h 2007-05-18 14:05:17 +0000
++++ guile-cairo/guile-cairo-enum-types.h 2007-05-20 22:36:42 +0000
+@@ -24,6 +24,10 @@
+ #ifndef __GUILE_CAIRO_ENUM_TYPES_H__
+ #define __GUILE_CAIRO_ENUM_TYPES_H__
+
++#if CAIRO_HAS_SVG_SURFACE
++#include <cairo-svg.h>
++#endif
++
+
+
+ SCM scm_from_cairo_status (cairo_status_t cval);
+
+=== modified file 'guile-cairo/guile-cairo.c'
+--- guile-cairo/guile-cairo.c 2007-05-18 16:27:47 +0000
++++ guile-cairo/guile-cairo.c 2007-05-20 18:32:44 +0000
+@@ -2281,6 +2281,11 @@
+ void
+ scm_init_cairo (void)
+ {
++ static int initialized = 0;
++
++ if (initialized)
++ return;
++
+ #ifndef SCM_MAGIC_SNARFER
+ #include "guile-cairo.x"
+ #endif
+@@ -2288,5 +2293,6 @@
+ scm_init_cairo_smob_types ();
+ scm_init_cairo_vector_types ();
+ scm_init_cairo_enum_types ();
+- scm_c_export (NULL);
++
++ initialized = 1;
+ }
+
+=== modified file 'guile-cairo/guile-cairo.h'
+--- guile-cairo/guile-cairo.h 2007-05-18 11:39:11 +0000
++++ guile-cairo/guile-cairo.h 2007-05-20 17:30:53 +0000
+@@ -24,6 +24,8 @@
+ #ifndef __GUILE_CAIRO_H__
+ #define __GUILE_CAIRO_H__
+
++#include <cairo.h>
++
+ #include <guile-cairo-smob-types.h>
+ #include <guile-cairo-enum-types.h>
+ #include <guile-cairo-vector-types.h>
+