summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-10-23 22:38:07 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-10-23 23:06:36 +0100
commitd41c5de5e436f9a3557615cad201e0779674e7c2 (patch)
treec9912f84164570434693b37277db90a4e7d29c97 /dev-scheme/guile-git/guile-git-0.4.0.ebuild
parentdev-python/semver: add pypy3 target (diff)
downloadgentoo-d41c5de5e436f9a3557615cad201e0779674e7c2.tar.gz
gentoo-d41c5de5e436f9a3557615cad201e0779674e7c2.tar.bz2
gentoo-d41c5de5e436f9a3557615cad201e0779674e7c2.zip
dev-scheme/guile-git: bump up to 0.4.0
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-scheme/guile-git/guile-git-0.4.0.ebuild')
-rw-r--r--dev-scheme/guile-git/guile-git-0.4.0.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-scheme/guile-git/guile-git-0.4.0.ebuild b/dev-scheme/guile-git/guile-git-0.4.0.ebuild
new file mode 100644
index 000000000000..c6779123e6af
--- /dev/null
+++ b/dev-scheme/guile-git/guile-git-0.4.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Guile bindings of git"
+HOMEPAGE="https://gitlab.com/guile-git/guile-git"
+SRC_URI="https://gitlab.com/guile-git/guile-git/uploads/2600bb0dfdfb00bfbe46811dccad51d8/guile-git-${PV}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# older libgit seems to be incompatible with guile-git bindings
+# https://github.com/trofi/nix-guix-gentoo/issues/7
+RDEPEND="
+ >=dev-scheme/guile-2.0.11:=
+ dev-scheme/bytestructures
+ >=dev-libs/libgit2-1:=
+"
+DEPEND="${RDEPEND}"
+
+RESTRICT=test # Tets suite needs a fix: https://gitlab.com/guile-git/guile-git/issues/18
+
+# guile generates ELF files without use of C or machine code
+# It's a portage's false positive. bug #677600
+QA_FLAGS_IGNORED='.*[.]go'
+
+src_prepare() {
+ default
+
+ # guile is trying to avoid recompilation by checking if file
+ # /usr/lib64/guile/2.2/site-ccache/<foo>
+ # is newer than
+ # <foo>
+ # In case it is instead of using <foo> guile
+ # loads system one (from potentially older version of package).
+ # To work it around we bump last modification timestamp of
+ # '*.scm' files.
+ # http://debbugs.gnu.org/cgi/bugreport.cgi?bug=38112
+ find "${S}" -name "*.scm" -exec touch {} + || die
+}
+
+src_test() {
+ emake check VERBOSE=1
+}