summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-02-26 13:27:08 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2020-02-26 13:27:08 +0000
commit3bd1a1b6a14d12cad6c98609a1cb1352201f7cea (patch)
tree0c12f57da285de73199314a8208f38f093dc6b11 /dev-scheme/guile-git
parentdev-libs/editline: bump up to 1.17.1 (diff)
downloadgentoo-3bd1a1b6a14d12cad6c98609a1cb1352201f7cea.tar.gz
gentoo-3bd1a1b6a14d12cad6c98609a1cb1352201f7cea.tar.bz2
gentoo-3bd1a1b6a14d12cad6c98609a1cb1352201f7cea.zip
dev-scheme/guile-git: bump up to 0.3.0
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-scheme/guile-git')
-rw-r--r--dev-scheme/guile-git/Manifest1
-rw-r--r--dev-scheme/guile-git/guile-git-0.3.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-scheme/guile-git/Manifest b/dev-scheme/guile-git/Manifest
index c809e13d6b63..415129e471b5 100644
--- a/dev-scheme/guile-git/Manifest
+++ b/dev-scheme/guile-git/Manifest
@@ -1 +1,2 @@
DIST guile-git-0.2.0.tar.gz 262570 BLAKE2B 5e2f326ab3afd23acb552cddf0175094f3efa817337b06219e048766b63df2a27a8fea38866452cc3137367410cfa6b9d4f7075f0586c4f8c429a5715dc194d1 SHA512 b5267130516db995132ff5bb5a19a68ccb3483d8ba5dff1a886a8acf4ecb43adf033638e59032b7a244eb4e35f72def3f40d7d071395154416e08dd5be86edf3
+DIST guile-git-0.3.0.tar.gz 275273 BLAKE2B 75c7e9b89446676adfa5e81c6cfeac9df19d77d1565450fdf892c01f9ef472dafe0ee7f8c8ff888421457d8e260e6f8e02a6e846952cbbff69ef4d75a467787c SHA512 98af9106c0b5d0f01c6d9550705c58116b8a38acb3c329e08822b8b81717c7c0147cfd74314e693c803e17b476af7b2f80ed2422652bbebfcc14271b654e839d
diff --git a/dev-scheme/guile-git/guile-git-0.3.0.ebuild b/dev-scheme/guile-git/guile-git-0.3.0.ebuild
new file mode 100644
index 000000000000..1f0eb73bd073
--- /dev/null
+++ b/dev-scheme/guile-git/guile-git-0.3.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Guile bindings of git"
+HOMEPAGE="https://gitlab.com/guile-git/guile-git"
+SRC_URI="https://gitlab.com/guile-git/guile-git/uploads/4c563d8e7e1ff84396abe8ca7011bcaf/guile-git-${PV}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-scheme/guile-2.0.11:=
+ dev-scheme/bytestructures
+ >=dev-libs/libgit2-0.28.0:=
+"
+DEPEND="${RDEPEND}"
+
+RESTRICT=test # Tets suite needs a fix: https://gitlab.com/guile-git/guile-git/issues/18
+
+src_prepare() {
+ default
+
+ # guile is trying to avoid recompilation by checking if file
+ # /usr/lib64/guile/2.2/site-ccache/<foo>
+ # is newer than
+ # <foo>
+ # In case it is instead of using <foo> guile
+ # loads system one (from potentially older version of package).
+ # To work it around we bump last modification timestamp of
+ # '*.scm' files.
+ # http://debbugs.gnu.org/cgi/bugreport.cgi?bug=38112
+ find "${S}" -name "*.scm" -exec touch {} + || die
+}
+
+src_test() {
+ emake check VERBOSE=1
+}