summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <rhill@gentoo.org>2015-09-18 19:53:16 -0600
committerRyan Hill <rhill@gentoo.org>2015-10-12 17:22:18 -0600
commit590cfd77349020fe506ac17520b6eae5d9b17e80 (patch)
tree0ff446e3d495899aa194d3b7136cada610a2ef19 /dev-scheme/guile
parentdev-scheme/guile: Fix breakage with GCC 5 (bug #560736) (diff)
downloadgentoo-590cfd77349020fe506ac17520b6eae5d9b17e80.tar.gz
gentoo-590cfd77349020fe506ac17520b6eae5d9b17e80.tar.bz2
gentoo-590cfd77349020fe506ac17520b6eae5d9b17e80.zip
dev-scheme/guile: Use emake install (bug #521546).
A sandbox violation was preventing us from using emake install rather than einstall. Gentoo-Bug: https://bugs.gentoo.org/521546
Diffstat (limited to 'dev-scheme/guile')
-rw-r--r--dev-scheme/guile/files/guile-1.8.8-sandbox.patch15
-rw-r--r--dev-scheme/guile/guile-1.8.8-r2.ebuild6
2 files changed, 19 insertions, 2 deletions
diff --git a/dev-scheme/guile/files/guile-1.8.8-sandbox.patch b/dev-scheme/guile/files/guile-1.8.8-sandbox.patch
new file mode 100644
index 000000000000..70d752fdae97
--- /dev/null
+++ b/dev-scheme/guile/files/guile-1.8.8-sandbox.patch
@@ -0,0 +1,15 @@
+Prevent sandbox violation when installing
+
+https://bugs.gentoo.org/521546
+
+--- a/guile-config/Makefile.am
++++ b/guile-config/Makefile.am
+@@ -39,8 +39,3 @@ guile-config: guile-config.in ${top_builddir}/libguile/libpath.h
+ -e s:@-GUILE_VERSION-@:${GUILE_VERSION}:
+ chmod +x guile-config.tmp
+ mv guile-config.tmp guile-config
+-
+-## Get rid of any copies of the configuration script under the old
+-## name, so people don't end up running ancient copies of it.
+-install-exec-local:
+- rm -f ${bindir}/build-guile
diff --git a/dev-scheme/guile/guile-1.8.8-r2.ebuild b/dev-scheme/guile/guile-1.8.8-r2.ebuild
index 2737d570aaf3..619d6784961f 100644
--- a/dev-scheme/guile/guile-1.8.8-r2.ebuild
+++ b/dev-scheme/guile/guile-1.8.8-r2.ebuild
@@ -34,7 +34,9 @@ src_prepare() {
"${FILESDIR}/${P}-gcc46.patch" \
"${FILESDIR}/${P}-gcc5.patch" \
"${FILESDIR}/${P}-makeinfo-5.patch" \
- "${FILESDIR}/${P}-gtexinfo-5.patch"
+ "${FILESDIR}/${P}-gtexinfo-5.patch" \
+ "${FILESDIR}/${P}-sandbox.patch"
+
sed \
-e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g" \
-e "/AM_PROG_CC_STDC/d" \
@@ -78,7 +80,7 @@ src_compile() {
}
src_install() {
- einstall
+ emake DESTDIR="${D}" install
dodoc AUTHORS ChangeLog GUILE-VERSION HACKING NEWS README THANKS