summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-01 05:52:29 +0000
committerSam James <sam@gentoo.org>2021-01-01 05:52:29 +0000
commitfb97c7de4b112b77e5205b7926bfaf1d38cc733d (patch)
treec0d18f8d3fe13fe0de9b90ec377c61f091223bf1 /dev-scheme/guile
parentsys-power/thermald: Stabilize 2.3-r1 amd64, #758794 (diff)
downloadgentoo-fb97c7de4b112b77e5205b7926bfaf1d38cc733d.tar.gz
gentoo-fb97c7de4b112b77e5205b7926bfaf1d38cc733d.tar.bz2
gentoo-fb97c7de4b112b77e5205b7926bfaf1d38cc733d.zip
dev-scheme/guile: fix build where stack grows upwards
Closes: https://bugs.gentoo.org/747049 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-scheme/guile')
-rw-r--r--dev-scheme/guile/files/guile-2.2.7-stack-up.patch17
-rw-r--r--dev-scheme/guile/guile-2.2.7.ebuild8
2 files changed, 23 insertions, 2 deletions
diff --git a/dev-scheme/guile/files/guile-2.2.7-stack-up.patch b/dev-scheme/guile/files/guile-2.2.7-stack-up.patch
new file mode 100644
index 000000000000..de291421c0be
--- /dev/null
+++ b/dev-scheme/guile/files/guile-2.2.7-stack-up.patch
@@ -0,0 +1,17 @@
+This patch (dropping an obsolete extra parameter to grow_stack) landed post
+2.2.7 and we're not likely to ever see a 2.2.8, as development has moved
+on to 3.x now.
+
+https://bugs.gentoo.org/747049
+https://www.mail-archive.com/guile-devel@gnu.org/msg15502.html
+--- a/libguile/continuations.c
++++ b/libguile/continuations.c
+@@ -302,7 +302,7 @@
+
+ #if SCM_STACK_GROWS_UP
+ if (dst + continuation->num_stack_items >= &stack_top_element)
+- grow_stack (cont, mra);
++ grow_stack (cont);
+ #else
+ dst -= continuation->num_stack_items;
+ if (dst <= &stack_top_element)
diff --git a/dev-scheme/guile/guile-2.2.7.ebuild b/dev-scheme/guile/guile-2.2.7.ebuild
index 61026da9a02b..6020cc995687 100644
--- a/dev-scheme/guile/guile-2.2.7.ebuild
+++ b/dev-scheme/guile/guile-2.2.7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -29,7 +29,11 @@ BDEPEND="
sys-devel/libtool
sys-devel/gettext"
-PATCHES=( "${FILESDIR}/${PN}-2.2.3-gentoo-sandbox.patch" )
+PATCHES=(
+ "${FILESDIR}/${PN}-2.2.3-gentoo-sandbox.patch"
+ "${FILESDIR}/${PN}-2.2.7-stack-up.patch"
+)
+
DOCS=( GUILE-VERSION HACKING README )
src_configure() {