summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-scheme/scheme48
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-scheme/scheme48')
-rw-r--r--dev-scheme/scheme48/Manifest2
-rw-r--r--dev-scheme/scheme48/files/50scheme48-gentoo.el10
-rw-r--r--dev-scheme/scheme48/files/scheme48-1.8-as-needed+fix_destdir.patch31
-rw-r--r--dev-scheme/scheme48/metadata.xml11
-rw-r--r--dev-scheme/scheme48/scheme48-1.8-r2.ebuild60
-rw-r--r--dev-scheme/scheme48/scheme48-1.9.2.ebuild68
6 files changed, 182 insertions, 0 deletions
diff --git a/dev-scheme/scheme48/Manifest b/dev-scheme/scheme48/Manifest
new file mode 100644
index 000000000000..e47464f58f2f
--- /dev/null
+++ b/dev-scheme/scheme48/Manifest
@@ -0,0 +1,2 @@
+DIST scheme48-1.8.tgz 3173151 SHA256 04a61ea28ef9d1f2f0e281fd6eb503f10afc94b0d3f34dbf376aedbe93eb1bb3 SHA512 1cae01ef1e282971ad0bad308a4d75fe24dcc629b09f711b54811d843f85f02cf3a728d19d44cdcc2699d071b27b2a0fb40c0ebb3a08db0f06a115e53e8b9e47 WHIRLPOOL c6748848df241d978c569768e39d0dced7c8a356342017e9777c018a63d38fe51f0eb28de3d2b34165a7c3658fb5f7dd4a72de1d1f585b9ea03b5ea5a33b5128
+DIST scheme48-1.9.2.tgz 3951356 SHA256 9c4921a90e95daee067cd2e9cc0ffe09e118f4da01c0c0198e577c4f47759df4 SHA512 a854e3c6f5b02c585fa125899dee276500b91e21cc773202fd4cb84f2e0566a0e19cc34b5f96a3265fab6bf06422e869a2e48433eb2d8fac83a1179fda62e2d1 WHIRLPOOL 6774a5488172b905577cfedabf454e54ec175df7582ea607ce99b39f6cedfa24366ecf1bcec3d60bc35132d483316cd192dcd9773e6d37af59c71de7ac0eed88
diff --git a/dev-scheme/scheme48/files/50scheme48-gentoo.el b/dev-scheme/scheme48/files/50scheme48-gentoo.el
new file mode 100644
index 000000000000..fe378e6a7081
--- /dev/null
+++ b/dev-scheme/scheme48/files/50scheme48-gentoo.el
@@ -0,0 +1,10 @@
+;;; scheme48 site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+
+(setq scheme-program-name "scheme48")
+(autoload 'run-scheme
+ "cmuscheme48"
+ "Run an inferior Scheme process."
+ t)
+
diff --git a/dev-scheme/scheme48/files/scheme48-1.8-as-needed+fix_destdir.patch b/dev-scheme/scheme48/files/scheme48-1.8-as-needed+fix_destdir.patch
new file mode 100644
index 000000000000..a6e050326871
--- /dev/null
+++ b/dev-scheme/scheme48/files/scheme48-1.8-as-needed+fix_destdir.patch
@@ -0,0 +1,31 @@
+--- Makefile.in.orig 2008-06-30 20:01:49.000000000 +0300
++++ Makefile.in 2008-06-30 20:08:12.000000000 +0300
+@@ -8,7 +8,7 @@
+ VPATH = @srcdir@
+ CC = @CC@
+ LD = @LD@
+-DEFS = @DEFS@ -D__COMPILING_SCHEME48_ITSELF__ -DS48_HOST_ARCHITECTURE=\"$(HOST_ARCHITECTURE)\"
++DEFS = @DEFS@ -D_GNU_SOURCE -D__COMPILING_SCHEME48_ITSELF__ -DS48_HOST_ARCHITECTURE=\"$(HOST_ARCHITECTURE)\"
+ LIBS = @LIBS@
+ CFLAGS = @CFLAGS@
+ CPPFLAGS =
+@@ -286,8 +286,8 @@
+ c/scheme48.exp c/scheme48.def
+ $(CC) $(LDFLAGS) $(LDFLAGS_VM) $(CFLAGS) -o $@ c/main.o \
+ $(OBJS) $(GC_OBJS) $(UNIX_OBJS) \
+- $(LIBOBJS) $(LIBS) \
+- $(EXTERNAL_OBJECTS)
++ $(LIBOBJS) \
++ $(EXTERNAL_OBJECTS) $(LIBS)
+ # Cygwin
+ if test -x /usr/bin/dlltool; then \
+ dlltool --dllname $(VM).exe --output-lib $(VM).a --def $(srcdir)/c/scheme48.def; \
+@@ -409,7 +409,7 @@
+ done
+
+ inst-config-script:
+- config_script=$(bindir)/$(CONFIG_SCRIPT) && \
++ config_script=$(DESTDIR)$(bindir)/$(CONFIG_SCRIPT) && \
+ sed -e 's,@incdir\@,$(incdir),g' \
+ -e 's,@libdir\@,$(libdir),g' \
+ -e 's,@CC\@,$(CC),g' \
diff --git a/dev-scheme/scheme48/metadata.xml b/dev-scheme/scheme48/metadata.xml
new file mode 100644
index 000000000000..150a7384a382
--- /dev/null
+++ b/dev-scheme/scheme48/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>scheme</herd>
+<longdescription lang="en">
+Scheme 48 is an implementation of Scheme written by Richard Kelsey and Jonathan
+Rees. It is based on a byte-code interpreter and is designed to be used as a
+testbed for experiments in implementation techniques and as an expository tool.
+</longdescription>
+</pkgmetadata>
+
diff --git a/dev-scheme/scheme48/scheme48-1.8-r2.ebuild b/dev-scheme/scheme48/scheme48-1.8-r2.ebuild
new file mode 100644
index 000000000000..9236dbef3534
--- /dev/null
+++ b/dev-scheme/scheme48/scheme48-1.8-r2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit elisp-common multilib eutils flag-o-matic
+
+DESCRIPTION="Scheme48 is an implementation of the Scheme Programming Language"
+HOMEPAGE="http://www.s48.org/"
+SRC_URI="http://www.s48.org/${PV}/${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="doc emacs"
+
+DEPEND="emacs? ( virtual/emacs )"
+RDEPEND="${DEPEND}"
+SITEFILE=50scheme48-gentoo.el
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-as-needed+fix_destdir.patch"
+ sed -i -e "s/\$(LD) /&\$(LFLAGS) /" Makefile.in || die #332007
+}
+
+src_compile() {
+ emake LFLAGS="$(raw-ldflags)"
+ if use emacs; then
+ elisp-compile "${S}"/emacs/cmuscheme48.el
+ fi
+}
+
+src_install() {
+ # weird parallel failures!
+ emake -j1 DESTDIR="${D}" install
+
+ if use emacs; then
+ elisp-install ${PN} emacs/cmuscheme48.el emacs/*.elc
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE}
+ fi
+
+ dodoc README
+ if use doc; then
+ dodoc doc/manual.ps doc/manual.pdf doc/*.txt
+ dohtml -r doc/html/*
+ docinto src
+ dodoc doc/src/*
+ fi
+
+ #this symlink clashes with gambit
+ rm "${ED}"/usr/bin/scheme-r5rs || die
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/dev-scheme/scheme48/scheme48-1.9.2.ebuild b/dev-scheme/scheme48/scheme48-1.9.2.ebuild
new file mode 100644
index 000000000000..80ef610bb3e5
--- /dev/null
+++ b/dev-scheme/scheme48/scheme48-1.9.2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit elisp-common multilib eutils flag-o-matic
+
+DESCRIPTION="Scheme48 is an implementation of the Scheme Programming Language"
+HOMEPAGE="http://www.s48.org/"
+SRC_URI="http://www.s48.org/${PV}/${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="doc emacs"
+
+DEPEND="emacs? ( virtual/emacs )"
+RDEPEND="${DEPEND}"
+SITEFILE=50scheme48-gentoo.el
+
+src_configure() {
+ append-cflags -fno-strict-aliasing
+ econf --docdir=/usr/share/doc/${P}
+}
+
+src_compile() {
+ emake
+ if use emacs; then
+ elisp-compile "${S}"/emacs/cmuscheme48.el
+ fi
+}
+
+src_install() {
+ # weird parallel failures!
+ emake -j1 DESTDIR="${D}" install
+
+ if use emacs; then
+ elisp-install ${PN} emacs/cmuscheme48.el emacs/*.elc
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE}
+ fi
+
+ dodoc README
+ if use doc; then
+ dodoc doc/*.txt
+ docinto src
+ dodoc doc/src/*
+ pushd "${ED}/usr/share/doc/${P}" > /dev/null
+ install -dm755 html
+ mv *.html *.css *.gif html/
+ popd > /dev/null
+ else
+ pushd "${ED}/usr/share/doc/${P}" > /dev/null
+ rm -f *.html *.css *.gif
+ rm -f manu*
+ popd > /dev/null
+ fi
+
+ #this symlink clashes with gambit
+ rm "${ED}"/usr/bin/scheme-r5rs || die
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}