summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-01-31 00:25:23 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-01-31 00:25:23 +0100
commit3482215046c22a35452f5c60e500fa5779d0b9a3 (patch)
tree12fbe67259565d9b7a6e4edbc4f026ee62b20648 /dev-scheme
parentsys-cluster/charliecloud: multiple fixes (diff)
downloadgentoo-3482215046c22a35452f5c60e500fa5779d0b9a3.tar.gz
gentoo-3482215046c22a35452f5c60e500fa5779d0b9a3.tar.bz2
gentoo-3482215046c22a35452f5c60e500fa5779d0b9a3.zip
dev-scheme/fibers: new package; add 1.2.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-scheme')
-rw-r--r--dev-scheme/fibers/Manifest1
-rw-r--r--dev-scheme/fibers/fibers-1.2.0.ebuild39
-rw-r--r--dev-scheme/fibers/metadata.xml22
3 files changed, 62 insertions, 0 deletions
diff --git a/dev-scheme/fibers/Manifest b/dev-scheme/fibers/Manifest
new file mode 100644
index 000000000000..fa9b8cd04f82
--- /dev/null
+++ b/dev-scheme/fibers/Manifest
@@ -0,0 +1 @@
+DIST fibers-1.2.0.tar.gz 104975 BLAKE2B d43175eeb03bf8ed1100e948423e0e7abb5ae1d859f3d4dd82f775b7b0ff477d99d1d2fffd9ccf0a1c19ab398f33eb1d7cefad30ba1991a63a63755ae38e6f07 SHA512 3113e287ab2b09c54c14a5c4d2b0330fcfc96281ec6f234655acadfb5a3c0a2872b602089e4fa025f42ba52749e71121062057029097f0957d71e97c0e4e9c71
diff --git a/dev-scheme/fibers/fibers-1.2.0.ebuild b/dev-scheme/fibers/fibers-1.2.0.ebuild
new file mode 100644
index 000000000000..ca3a3103affc
--- /dev/null
+++ b/dev-scheme/fibers/fibers-1.2.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Lightweight concurrency facility for Guile Scheme"
+HOMEPAGE="https://github.com/wingo/fibers/
+ https://github.com/wingo/fibers/wiki/Manual/"
+SRC_URI="https://github.com/wingo/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="strip"
+
+RDEPEND=">=dev-scheme/guile-2.1.7:="
+DEPEND="${RDEPEND}"
+
+# guile generates ELF files without use of C or machine code
+# It's a portage's false positive. bug #677600
+QA_PREBUILT='*[.]go'
+
+src_prepare() {
+ default
+
+ # http://debbugs.gnu.org/cgi/bugreport.cgi?bug=38112
+ find "${S}" -name "*.scm" -exec touch {} + || die
+
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ find "${D}" -name "*.la" -delete || die
+}
diff --git a/dev-scheme/fibers/metadata.xml b/dev-scheme/fibers/metadata.xml
new file mode 100644
index 000000000000..c95b5f88b1d8
--- /dev/null
+++ b/dev-scheme/fibers/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>scheme@gentoo.org</email>
+ <name>Gentoo Scheme Project</name>
+ </maintainer>
+ <longdescription>
+ Fibers is a Guile library that implements a a lightweight concurrency
+ facility, inspired by systems like Concurrent ML, Go, and Erlang. A fiber
+ is like a "goroutine" from the Go language: a lightweight thread-like
+ abstraction. Systems built with Fibers can scale up to millions of
+ concurrent fibers, tens of thousands of concurrent socket connections, and
+ many parallel cores. The Fibers library also provides Concurrent ML-like
+ channels for communication between fibers.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://gitlab.com/wingo/fibers/-/issues/</bugs-to>
+ <remote-id type="github">wingo/fibers</remote-id>
+ </upstream>
+</pkgmetadata>