summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTupone Alfredo <tupone@gentoo.org>2018-10-29 08:57:47 +0100
committerTupone Alfredo <tupone@gentoo.org>2018-10-29 08:57:47 +0100
commit12bb26e7487c4fb04cbfd2fe45a04876a3b1e1b0 (patch)
tree908129902b29f631e863e672468ba63a00a3d12b /dev-tcltk/tclpython
parentdev-libs/libgit2: Remove vulnerable versions (diff)
downloadgentoo-12bb26e7487c4fb04cbfd2fe45a04876a3b1e1b0.tar.gz
gentoo-12bb26e7487c4fb04cbfd2fe45a04876a3b1e1b0.tar.bz2
gentoo-12bb26e7487c4fb04cbfd2fe45a04876a3b1e1b0.zip
dev-tcltk/tclpython: Version bump to 5.0
Signed-off-by: Alfredo Tupone <tupone@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
Diffstat (limited to 'dev-tcltk/tclpython')
-rw-r--r--dev-tcltk/tclpython/Manifest1
-rw-r--r--dev-tcltk/tclpython/files/tclpython-5.0-gentoo.patch12
-rw-r--r--dev-tcltk/tclpython/tclpython-5.0.ebuild51
3 files changed, 64 insertions, 0 deletions
diff --git a/dev-tcltk/tclpython/Manifest b/dev-tcltk/tclpython/Manifest
index 54cd35289592..9bd7a795d516 100644
--- a/dev-tcltk/tclpython/Manifest
+++ b/dev-tcltk/tclpython/Manifest
@@ -1 +1,2 @@
DIST tclpython-4.1.tar.bz2 10580 BLAKE2B 98d4783cc52bc907c21d50ee393e25ee084b449db7c393c16b0b1f0420469bd0904d16dc2a6806b776dad7dabd521e5f2e8cc942c720d9e69750385302355608 SHA512 5f08e7129a7d9afeb1ac6bf1ab1c83ad3bb481593c9516c0653c7b4ba0dfb1b3129a336e64b998cec8ef2d2377a6a366b73c640d25839ab280d5079c0b220d54
+DIST tclpython-5.0.tar.gz 19327 BLAKE2B bad25a6eb04dbcd9ca3e9bc81d44f098f31f2acf367ecc32307596d5da3ed95752b3c60d9ee74fc04e21669e0361f0790edad3ad5793c78ece4904beacd92900 SHA512 fe15218fe00e921384dbd9611685b86cb6dfacb515a95545079550aeadaaafc3964e6ef0594a268a3fd900f40d178659e8b7f6f2a6d9aa507b59a8be0bd116af
diff --git a/dev-tcltk/tclpython/files/tclpython-5.0-gentoo.patch b/dev-tcltk/tclpython/files/tclpython-5.0-gentoo.patch
new file mode 100644
index 000000000000..7f4aa0bf5a2e
--- /dev/null
+++ b/dev-tcltk/tclpython/files/tclpython-5.0-gentoo.patch
@@ -0,0 +1,12 @@
+--- a/Makefile 2018-10-28 17:21:20.274137396 +0100
++++ b/Makefile 2018-10-28 17:21:47.696694473 +0100
+@@ -62,7 +62,8 @@
+ $(OUTPUT_DIR)/pkgIndex.tcl:pkg/pkgIndex.tcl
+ cp -t $(dir $@) $^
+
+-package: $(OUTPUT_DIR)/$(LIBRARY) $(OUTPUT_DIR)/pkgIndex.tcl
++package: $(OUTPUT_DIR)/$(LIBRARY)
++ ${MAKE} $(OUTPUT_DIR)/pkgIndex.tcl
+
+ ifneq ($(MAKECMDGOALS), clean)
+ -include $(DEPEND)
diff --git a/dev-tcltk/tclpython/tclpython-5.0.ebuild b/dev-tcltk/tclpython/tclpython-5.0.ebuild
new file mode 100644
index 000000000000..e4a170a603e8
--- /dev/null
+++ b/dev-tcltk/tclpython/tclpython-5.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit multilib python-single-r1 toolchain-funcs
+
+DESCRIPTION="Python package for Tcl"
+HOMEPAGE="http://jfontain.free.fr/tclpython.htm"
+SRC_URI="https://github.com/amykyta3/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ dev-lang/tcl:0="
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+
+src_compile() {
+ local PKG_NAME
+ if python_is_python3; then
+ PKG_NAME=tclpython3
+ else
+ PKG_NAME=tclpython
+ fi
+ emake PKG_NAME=${PKG_NAME} CC=$(tc-getCC)
+}
+
+src_install() {
+ if python_is_python3; then
+ insinto /usr/$(get_libdir)
+ doins -r build/tclpython3/tclpython3
+ fperms 775 /usr/$(get_libdir)/tclpython3/tclpython3.so.${PV}
+ dosym tclpython3.so.${PV} /usr/$(get_libdir)/tclpython3/tclpython3.so
+ else
+ insinto /usr/$(get_libdir)
+ doins -r build/tclpython/tclpython
+ fperms 775 /usr/$(get_libdir)/tclpython/tclpython.so.${PV}
+ dosym tclpython.so.${PV} /usr/$(get_libdir)/tclpython/tclpython3.so
+ fi
+
+ dodoc README.md VERSION.md
+}