summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-tcltk/tclreadline/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-tcltk/tclreadline/files')
-rw-r--r--dev-tcltk/tclreadline/files/tclreadline-2.1.0-alloc-free.patch121
-rw-r--r--dev-tcltk/tclreadline/files/tclreadline-2.1.0-gold.patch15
-rw-r--r--dev-tcltk/tclreadline/files/tclreadline-2.1.0-rl-executing-macro.patch128
-rw-r--r--dev-tcltk/tclreadline/files/tclreadline-2.1.0-rl-history-expand.patch35
-rw-r--r--dev-tcltk/tclreadline/files/tclreadline-2.1.0-rl-prompt.patch12
5 files changed, 311 insertions, 0 deletions
diff --git a/dev-tcltk/tclreadline/files/tclreadline-2.1.0-alloc-free.patch b/dev-tcltk/tclreadline/files/tclreadline-2.1.0-alloc-free.patch
new file mode 100644
index 000000000000..6694c29f6042
--- /dev/null
+++ b/dev-tcltk/tclreadline/files/tclreadline-2.1.0-alloc-free.patch
@@ -0,0 +1,121 @@
+diff -ur a/tclreadline.c b/tclreadline.c
+--- a/tclreadline.c 2000-09-20 19:44:34.000000000 +0200
++++ b/tclreadline.c 2013-11-18 10:35:13.889610060 +0100
+@@ -343,7 +343,9 @@
+ return TCL_ERROR;
+ } else if (3 == objc) {
+- if (tclrl_custom_completer)
++ if (tclrl_custom_completer) {
+- FREE(tclrl_custom_completer);
++ free(tclrl_custom_completer);
++ tclrl_custom_completer = NULL;
++ }
+ if (!blank_line(Tcl_GetStringFromObj(objv[2], 0)))
+ tclrl_custom_completer =
+ stripwhite(strdup(Tcl_GetStringFromObj(objv[2], 0)));
+@@ -378,7 +380,9 @@
+ return TCL_ERROR;
+ } else if (3 == objc) {
+- if (tclrl_eof_string)
++ if (tclrl_eof_string) {
+- FREE(tclrl_eof_string);
++ free(tclrl_eof_string);
++ tclrl_eof_string = NULL;
++ }
+ if (!blank_line(Tcl_GetStringFromObj(objv[2], 0)))
+ tclrl_eof_string =
+ stripwhite(strdup(Tcl_GetStringFromObj(objv[2], 0)));
+@@ -506,10 +510,16 @@
+ if (status >= 1) {
+ /* TODO: make this a valid tcl output */
+ printf("%s\n", expansion);
++ free(ptr);
++ free(expansion);
++ return;
+ } else if (-1 == status) {
+ Tcl_AppendResult
+ (tclrl_interp, "error in history expansion\n", (char*) NULL);
+ TclReadlineTerminate(TCL_ERROR);
++ free(ptr);
++ free(expansion);
++ return;
+ }
+ /**
+ * TODO: status == 2 ...
+@@ -544,8 +554,8 @@
+ * tell the calling routines to terminate.
+ */
+ TclReadlineTerminate(LINE_COMPLETE);
+- FREE(ptr);
+- FREE(expansion);
++ free(ptr);
++ free(expansion);
+ }
+ }
+
+@@ -673,7 +683,7 @@
+ strcpy(rl_line_buffer, expansion);
+ rl_end = strlen(expansion);
+ rl_point += strlen(expansion) - oldlen;
+- FREE(expansion);
++ free(expansion);
+ /*
+ * TODO:
+ * because we return 0 == matches,
+@@ -682,7 +690,8 @@
+ */
+ return matches;
+ }
+- FREE(expansion);
++ free(expansion);
++ expansion = NULL;
+ }
+
+ if (tclrl_custom_completer) {
+@@ -699,15 +710,19 @@
+ state = Tcl_VarEval(tclrl_interp, tclrl_custom_completer,
+ " \"", quoted_text, "\" ", start_s, " ", end_s,
+ " \"", quoted_rl_line_buffer, "\"", (char*) NULL);
+- FREE(quoted_text);
+- FREE(quoted_rl_line_buffer);
+ if (TCL_OK != state) {
+ Tcl_AppendResult (tclrl_interp, " `", tclrl_custom_completer,
+ " \"", quoted_text, "\" ", start_s, " ", end_s,
+ " \"", quoted_rl_line_buffer, "\"' failed.", (char*) NULL);
+ TclReadlineTerminate(state);
++ free(quoted_text);
++ free(quoted_rl_line_buffer);
+ return matches;
+ }
++ free(quoted_text);
++ quoted_text = NULL;
++ free(quoted_rl_line_buffer);
++ quoted_rl_line_buffer = NULL;
+ obj = Tcl_GetObjResult(tclrl_interp);
+ status = Tcl_ListObjGetElements(tclrl_interp, obj, &objc, &objv);
+ if (TCL_OK != status)
+@@ -715,12 +732,12 @@
+
+ if (objc) {
+ int i, length;
+- matches = (char**) MALLOC(sizeof(char*) * (objc + 1));
++ matches = (char**) malloc(sizeof(char*) * (objc + 1));
+ for (i = 0; i < objc; i++) {
+ matches[i] = strdup(Tcl_GetStringFromObj(objv[i], &length));
+ if (1 == objc && !strlen(matches[i])) {
+- FREE(matches[i]);
++ free(matches[i]);
+- FREE(matches);
++ free(matches);
+ Tcl_ResetResult(tclrl_interp); /* clear result space */
+ return (char**) NULL;
+ }
+@@ -735,7 +752,7 @@
+ */
+ if (2 == objc && !strlen(matches[1])) {
+ i--;
+- FREE(matches[1]);
++ free(matches[1]);
+ rl_completion_append_character = '\0';
+ }
+
diff --git a/dev-tcltk/tclreadline/files/tclreadline-2.1.0-gold.patch b/dev-tcltk/tclreadline/files/tclreadline-2.1.0-gold.patch
new file mode 100644
index 000000000000..5550c89879c8
--- /dev/null
+++ b/dev-tcltk/tclreadline/files/tclreadline-2.1.0-gold.patch
@@ -0,0 +1,15 @@
+ Makefile.am | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Makefile.am b/Makefile.am
+index 68d78f1..03dbf06 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -20,6 +20,7 @@ include_HEADERS = tclreadline.h
+ INCLUDES = -I$(TCL_INCLUDE_DIR) -I$(READLINE_INCLUDE_DIR)
+
+ ## libtclreadline_la_LIBADD = $(LIBS)
++libtclreadline_la_LIBADD = $(TCL_LIB_SPEC) -lreadline
+ libtclreadline_la_LDFLAGS = -release $(MAJOR).$(MINOR).$(PATCHLEVEL)
+
+ tclrldir = @TCLRL_DIR@
diff --git a/dev-tcltk/tclreadline/files/tclreadline-2.1.0-rl-executing-macro.patch b/dev-tcltk/tclreadline/files/tclreadline-2.1.0-rl-executing-macro.patch
new file mode 100644
index 000000000000..683622e0d54c
--- /dev/null
+++ b/dev-tcltk/tclreadline/files/tclreadline-2.1.0-rl-executing-macro.patch
@@ -0,0 +1,128 @@
+diff -ur a/configure.ac b/configure.ac
+--- a/configure.ac 2000-12-08 01:45:45.000000000 +0100
++++ b/configure.ac 2013-11-15 13:37:36.490520853 +0100
+@@ -182,29 +182,36 @@
+ [ --with-readline-library=DIR
+ lib spec to readline (e.g. '-L/usr/local/lib -lreadline')],
+ LIBS="$LIBS $withval",
+- AC_CHECK_LIB(readline, rl_callback_read_char, ,
+- AC_MSG_RESULT([
+- Your readline version does not support readline's alternate interface.
+- Please upgrade to readline >= 2.2 and retry.
+- ])
+- exit
++ AC_SEARCH_LIBS(rl_callback_read_char, readline, ,
++ AC_MSG_RESULT([
++ Your readline version does not support readline's alternate interface.
++ Please upgrade to readline >= 2.2 and retry.
++ ])
++ exit
+ )
+ )
+
+
+
+-# check for readline's (macro.c) private variable
+-# _rl_executing_macro.
++# check for readline's rl_executing_macro
++# (could be macro.c's private variable _rl_executing_macro).
+
+-AC_MSG_CHECKING([for _rl_executing_macro in -lreadline])
+-AC_TRY_LINK(,[
++AC_CHECK_DECL(rl_executing_macro
++, AC_DEFINE(EXECUTING_MACRO_NAME, rl_executing_macro,
++ [ Define the name of the executing macro variable in libreadline. ])
++, AC_MSG_CHECKING([for _rl_executing_macro in -lreadline])
++ AC_TRY_LINK(,[
+ extern char* _rl_executing_macro;
+ _rl_executing_macro = (char*) 0;
+-],
+- AC_MSG_RESULT(yes);
++ ]
++ , AC_MSG_RESULT(yes)
+ AC_DEFINE(EXECUTING_MACRO_HACK, 1,
+- [ Define if _rl_executing_macro is resolved in libreadline. ]),
+- AC_MSG_RESULT(no))
++ [ Define if EXECUTING_MACRO_NAME is resolved in libreadline. ])
++ AC_DEFINE(EXECUTING_MACRO_NAME, _rl_executing_macro,
++ [ Define the name of the executing macro variable in libreadline. ])
++ , AC_MSG_RESULT(no))
++, [AC_INCLUDES_DEFAULT
++#include "$READLINE_INCLUDE_DIR/readline.h"])
+
+ # check for readline's rl_cleanup_after_signal
+
+diff -ur a/tclreadline.c b/tclreadline.c
+--- a/tclreadline.c 2000-09-20 19:44:34.000000000 +0200
++++ b/tclreadline.c 2013-11-15 11:09:42.269771129 +0100
+@@ -41,7 +41,7 @@
+ * We need it here to decide, if we should read more
+ * characters from a macro. Dirty, but it should work.
+ */
+-extern char* _rl_executing_macro;
++extern char* EXECUTING_MACRO_NAME;
+ #endif
+
+ #include "tclreadline.h"
+@@ -249,14 +249,14 @@
+ tclrl_state = LINE_PENDING;
+
+ while (!TclReadlineLineComplete()) {
+-#ifdef EXECUTING_MACRO_HACK
++#ifdef EXECUTING_MACRO_NAME
+ /**
+ * check first, if more characters are
+ * available from _rl_executing_macro,
+ * because Tcl_DoOneEvent() will (naturally)
+ * not detect this `event'.
+ */
+- if (_rl_executing_macro)
++ if (EXECUTING_MACRO_NAME)
+ TclReadlineReadHandler((ClientData) NULL, TCL_READABLE);
+ else
+ #endif
+@@ -468,17 +468,17 @@
+ TclReadlineReadHandler(ClientData clientData, int mask)
+ {
+ if (mask & TCL_READABLE) {
+-#ifdef EXECUTING_MACRO_HACK
++#ifdef EXECUTING_MACRO_NAME
+ do {
+ #endif
+ rl_callback_read_char();
+-#ifdef EXECUTING_MACRO_HACK
++#ifdef EXECUTING_MACRO_NAME
+ /**
+ * check, if we're inside a macro and
+ * if so, read all macro characters
+ * until the next eol.
+ */
+- } while (_rl_executing_macro && !TclReadlineLineComplete());
++ } while (EXECUTING_MACRO_NAME && !TclReadlineLineComplete());
+ #endif
+ }
+ }
+@@ -517,12 +517,12 @@
+
+ Tcl_AppendResult(tclrl_interp, expansion, (char*) NULL);
+
+-#ifdef EXECUTING_MACRO_HACK
++#ifdef EXECUTING_MACRO_NAME
+ /**
+ * don't stuff macro lines
+ * into readline's history.
+ */
+- if(!_rl_executing_macro) {
++ if(!EXECUTING_MACRO_NAME) {
+ #endif
+ /**
+ * don't stuff empty lines
+@@ -537,7 +537,7 @@
+ if (tclrl_last_line)
+ free(tclrl_last_line);
+ tclrl_last_line = strdup(expansion);
+-#ifdef EXECUTING_MACRO_HACK
++#ifdef EXECUTING_MACRO_NAME
+ }
+ #endif
+ /**
diff --git a/dev-tcltk/tclreadline/files/tclreadline-2.1.0-rl-history-expand.patch b/dev-tcltk/tclreadline/files/tclreadline-2.1.0-rl-history-expand.patch
new file mode 100644
index 000000000000..6e4d5270e41a
--- /dev/null
+++ b/dev-tcltk/tclreadline/files/tclreadline-2.1.0-rl-history-expand.patch
@@ -0,0 +1,35 @@
+diff -ur a/tclreadline.c b/tclreadline.c
+--- a/tclreadline.c 2013-11-16 20:14:28.876272386 +0100
++++ b/tclreadline.c 2013-11-16 20:14:24.191390550 +0100
+@@ -503,25 +503,22 @@
+ char* expansion = (char*) NULL;
+ int status = history_expand(ptr, &expansion);
+
+- if (status >= 1) {
++ if (status >= 2) {
+ /* TODO: make this a valid tcl output */
+ printf("%s\n", expansion);
+ free(ptr);
+ free(expansion);
+ return;
+- } else if (-1 == status) {
++ } else if (status <= -1) {
+ Tcl_AppendResult
+- (tclrl_interp, "error in history expansion\n", (char*) NULL);
++ (tclrl_interp, "error in history expansion: ", expansion, "\n", (char*) NULL);
+ TclReadlineTerminate(TCL_ERROR);
+ free(ptr);
+ free(expansion);
+ return;
+- }
+- /**
+- * TODO: status == 2 ...
+- */
+-
+- Tcl_AppendResult(tclrl_interp, expansion, (char*) NULL);
++ } else {
++ Tcl_AppendResult(tclrl_interp, expansion, (char*) NULL);
++ }
+
+ #ifdef EXECUTING_MACRO_HACK
+ /**
diff --git a/dev-tcltk/tclreadline/files/tclreadline-2.1.0-rl-prompt.patch b/dev-tcltk/tclreadline/files/tclreadline-2.1.0-rl-prompt.patch
new file mode 100644
index 000000000000..a10a404100d3
--- /dev/null
+++ b/dev-tcltk/tclreadline/files/tclreadline-2.1.0-rl-prompt.patch
@@ -0,0 +1,12 @@
+diff -ur a/tclreadline.c b/tclreadline.c
+--- a/tclreadline.c 2013-11-16 20:14:28.876272386 +0100
++++ b/tclreadline.c 2013-11-16 20:37:47.455986902 +0100
+@@ -234,7 +234,7 @@
+
+ rl_callback_handler_install(
+ objc == 3 ? Tcl_GetStringFromObj(objv[2], 0)
+- : "%", TclReadlineLineCompleteHandler);
++ : "% ", TclReadlineLineCompleteHandler);
+
+ Tcl_CreateFileHandler(0, TCL_READABLE,
+ TclReadlineReadHandler, (ClientData) NULL);