summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-03-16 08:45:09 +0100
committerAlfredo Tupone <tupone@gentoo.org>2023-03-16 08:45:30 +0100
commit2f0b759b1aa4bcea8226682f257cf77625db2667 (patch)
tree0a694bbdae8f412c175a3724bcef5662b5ae3e11 /dev-tcltk/tkimg
parentnet-analyzer/zabbix: bump to 6.2.8 (diff)
downloadgentoo-2f0b759b1aa4bcea8226682f257cf77625db2667.tar.gz
gentoo-2f0b759b1aa4bcea8226682f257cf77625db2667.tar.bz2
gentoo-2f0b759b1aa4bcea8226682f257cf77625db2667.zip
dev-tcltk/tkimg: fix line endings
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-tcltk/tkimg')
-rw-r--r--dev-tcltk/tkimg/files/tkimg-1.4.14-gcc11.patch98
-rw-r--r--dev-tcltk/tkimg/tkimg-1.4.14-r2.ebuild2
2 files changed, 51 insertions, 49 deletions
diff --git a/dev-tcltk/tkimg/files/tkimg-1.4.14-gcc11.patch b/dev-tcltk/tkimg/files/tkimg-1.4.14-gcc11.patch
index 6f9e575db2ac..9b889315efb3 100644
--- a/dev-tcltk/tkimg/files/tkimg-1.4.14-gcc11.patch
+++ b/dev-tcltk/tkimg/files/tkimg-1.4.14-gcc11.patch
@@ -16,59 +16,59 @@
--- a/tiff/tiffZip.c 2023-03-14 19:04:42.869354563 +0100
+++ b/tiff/tiffZip.c 2023-03-14 19:05:14.768849607 +0100
@@ -22,6 +22,7 @@
- * OF THIS SOFTWARE.
- */
-
-+#include <stdint.h>
- #include "tiffInt.h"
-
- /*
+ * OF THIS SOFTWARE.
+ */
+
++#include <stdint.h>
+ #include "tiffInt.h"
+
+ /*
@@ -233,7 +234,7 @@
- we need to simplify this code to reflect a ZLib that is likely updated
- to deal with 8byte memory sizes, though this code will respond
- appropriately even before we simplify it */
-- sp->stream.avail_out = (uint64)tif->tif_rawdatasize <= 0xFFFFFFFFU ? (uInt)tif->tif_rawdatasize : 0xFFFFFFFFU;
-+ sp->stream.avail_out = (uint64_t)tif->tif_rawdatasize <= 0xFFFFFFFFU ? (uInt)tif->tif_rawdatasize : 0xFFFFFFFFU;
- return (deflateReset(&sp->stream) == Z_OK);
- }
-
+ we need to simplify this code to reflect a ZLib that is likely updated
+ to deal with 8byte memory sizes, though this code will respond
+ appropriately even before we simplify it */
+- sp->stream.avail_out = (uint64)tif->tif_rawdatasize <= 0xFFFFFFFFU ? (uInt)tif->tif_rawdatasize : 0xFFFFFFFFU;
++ sp->stream.avail_out = (uint64_t)tif->tif_rawdatasize <= 0xFFFFFFFFU ? (uInt)tif->tif_rawdatasize : 0xFFFFFFFFU;
+ return (deflateReset(&sp->stream) == Z_OK);
+ }
+
--- a/tiff/tiffPixar.c 2023-03-14 20:52:33.865532115 +0100
+++ b/tiff/tiffPixar.c 2023-03-14 20:54:14.606973646 +0100
@@ -592,8 +592,8 @@
- #define DecoderState(tif) ((PixarLogState*) (tif)->tif_data)
- #define EncoderState(tif) ((PixarLogState*) (tif)->tif_data)
-
--static int PixarLogEncode(TIFF* tif, uint8_t bp, tmsize_t cc, uint16_t s);
--static int PixarLogDecode(TIFF* tif, uint8_t op, tmsize_t occ, uint16_t s);
-+static int PixarLogEncode(TIFF* tif, uint8_t *bp, tmsize_t cc, uint16_t s);
-+static int PixarLogDecode(TIFF* tif, uint8_t *op, tmsize_t occ, uint16_t s);
-
- #define PIXARLOGDATAFMT_UNKNOWN -1
-
+ #define DecoderState(tif) ((PixarLogState*) (tif)->tif_data)
+ #define EncoderState(tif) ((PixarLogState*) (tif)->tif_data)
+
+-static int PixarLogEncode(TIFF* tif, uint8_t bp, tmsize_t cc, uint16_t s);
+-static int PixarLogDecode(TIFF* tif, uint8_t op, tmsize_t occ, uint16_t s);
++static int PixarLogEncode(TIFF* tif, uint8_t *bp, tmsize_t cc, uint16_t s);
++static int PixarLogDecode(TIFF* tif, uint8_t *op, tmsize_t occ, uint16_t s);
+
+ #define PIXARLOGDATAFMT_UNKNOWN -1
+
@@ -747,7 +747,7 @@
- }
-
- static int
--PixarLogDecode(TIFF* tif, uint8_t op, tmsize_t occ, uint16_t s)
-+PixarLogDecode(TIFF* tif, uint8_t *op, tmsize_t occ, uint16_t s)
- {
- static const char module[] = "PixarLogDecode";
- TIFFDirectory *td = &tif->tif_dir;
+ }
+
+ static int
+-PixarLogDecode(TIFF* tif, uint8_t op, tmsize_t occ, uint16_t s)
++PixarLogDecode(TIFF* tif, uint8_t *op, tmsize_t occ, uint16_t s)
+ {
+ static const char module[] = "PixarLogDecode";
+ TIFFDirectory *td = &tif->tif_dir;
@@ -1111,7 +1111,7 @@
- * Encode a chunk of pixels.
- */
- static int
--PixarLogEncode(TIFF* tif, uint8_t bp, tmsize_t cc, uint16_t s)
-+PixarLogEncode(TIFF* tif, uint8_t *bp, tmsize_t cc, uint16_t s)
- {
- static const char module[] = "PixarLogEncode";
- TIFFDirectory *td = &tif->tif_dir;
+ * Encode a chunk of pixels.
+ */
+ static int
+-PixarLogEncode(TIFF* tif, uint8_t bp, tmsize_t cc, uint16_t s)
++PixarLogEncode(TIFF* tif, uint8_t *bp, tmsize_t cc, uint16_t s)
+ {
+ static const char module[] = "PixarLogEncode";
+ TIFFDirectory *td = &tif->tif_dir;
@@ -1411,7 +1411,7 @@
- /*
- * Allocate state block so tag methods have storage to record values.
- */
-- tif->tif_data = (uint8_t) TkimgTIFFmalloc(sizeof (PixarLogState));
-+ tif->tif_data = (uint8_t *) TkimgTIFFmalloc(sizeof (PixarLogState));
- if (tif->tif_data == NULL)
- goto bad;
- sp = (PixarLogState*) tif->tif_data;
+ /*
+ * Allocate state block so tag methods have storage to record values.
+ */
+- tif->tif_data = (uint8_t) TkimgTIFFmalloc(sizeof (PixarLogState));
++ tif->tif_data = (uint8_t *) TkimgTIFFmalloc(sizeof (PixarLogState));
+ if (tif->tif_data == NULL)
+ goto bad;
+ sp = (PixarLogState*) tif->tif_data;
diff --git a/dev-tcltk/tkimg/tkimg-1.4.14-r2.ebuild b/dev-tcltk/tkimg/tkimg-1.4.14-r2.ebuild
index 904cc6621894..38c87072f7ed 100644
--- a/dev-tcltk/tkimg/tkimg-1.4.14-r2.ebuild
+++ b/dev-tcltk/tkimg/tkimg-1.4.14-r2.ebuild
@@ -51,6 +51,8 @@ src_prepare() {
libjpeg/jpegtclDecls.h \
zlib/zlibtclDecls.h \
libpng/pngtclDecls.h \
+ tiff/tiffZip.c \
+ tiff/tiffPixar.c \
libtiff/tifftclDecls.h
# libtiff unbundle is problematic