summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-tcltk/tls
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-tcltk/tls')
-rw-r--r--dev-tcltk/tls/Manifest1
-rw-r--r--dev-tcltk/tls/files/tls-1.5.0-bad-version.patch10
-rw-r--r--dev-tcltk/tls/metadata.xml8
-rw-r--r--dev-tcltk/tls/tls-1.6-r3.ebuild45
4 files changed, 64 insertions, 0 deletions
diff --git a/dev-tcltk/tls/Manifest b/dev-tcltk/tls/Manifest
new file mode 100644
index 000000000000..a16147d3356d
--- /dev/null
+++ b/dev-tcltk/tls/Manifest
@@ -0,0 +1 @@
+DIST tls1.6-src.tar.gz 168043 SHA256 adec50143a9ad634a671d24f7c7bbf2455487eb5f12d290f41797c32a98b93f3 SHA512 beaca2653a11924f022e28254cef5071ecb8ab2e2355496d278fcab1bdcc46424aa58d2fe176aea26ec4fbe4416a912b5af8e8e69571c8a5301b7921ecf48383 WHIRLPOOL 5769eccd4df94558d7b5cdaa7234f4b248e3d8108686c3104bfa53a709a444088cdbf51b9660ecaa1f213c9391afbf81108ed330fe41bed3409d3c9364ac9790
diff --git a/dev-tcltk/tls/files/tls-1.5.0-bad-version.patch b/dev-tcltk/tls/files/tls-1.5.0-bad-version.patch
new file mode 100644
index 000000000000..a55a00c6d5f0
--- /dev/null
+++ b/dev-tcltk/tls/files/tls-1.5.0-bad-version.patch
@@ -0,0 +1,10 @@
+diff -ur tls1.5_org/pkgIndex.tcl.in tls1.5/pkgIndex.tcl.in
+--- tls1.5_org/pkgIndex.tcl.in 2007-04-05 23:09:11.000000000 +0200
++++ tls1.5/pkgIndex.tcl.in 2007-04-05 23:09:40.000000000 +0200
+@@ -5,5 +5,5 @@
+ # replace the original which didn't include the commands from "tls.tcl".
+ #
+
+-package ifneeded tls 1.5 "[list load [file join $dir @RELPATH@ @tls_LIB_FILE@] ] ; [list source [file join $dir tls.tcl] ]"
++package ifneeded tls 1.50 "[list load [file join $dir @RELPATH@ @tls_LIB_FILE@] ] ; [list source [file join $dir tls.tcl] ]"
+
diff --git a/dev-tcltk/tls/metadata.xml b/dev-tcltk/tls/metadata.xml
new file mode 100644
index 000000000000..4c5c70d2f177
--- /dev/null
+++ b/dev-tcltk/tls/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>tcltk</herd>
+ <upstream>
+ <remote-id type="sourceforge">tls</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-tcltk/tls/tls-1.6-r3.ebuild b/dev-tcltk/tls/tls-1.6-r3.ebuild
new file mode 100644
index 000000000000..5d505ed32b8c
--- /dev/null
+++ b/dev-tcltk/tls/tls-1.6-r3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib
+
+MY_P="${PN}${PV}"
+
+DESCRIPTION="TLS OpenSSL extension to Tcl"
+HOMEPAGE="http://tls.sourceforge.net/"
+SRC_URI="mirror://sourceforge/tls/${MY_P}-src.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="tk"
+
+DEPEND="
+ dev-lang/tcl:0=
+ dev-libs/openssl:0=
+ tk? ( dev-lang/tk:0= )"
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ econf \
+ --with-ssl-dir="${EPREFIX}/usr" \
+ --with-tcl="${EPREFIX}/usr/$(get_libdir)"
+}
+
+src_install() {
+ default
+ dohtml tls.htm
+
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ # this is ugly, but fixing the makefile mess is even worse
+ local loc=usr/$(get_libdir)/tls1.6/libtls1.6.dylib
+ install_name_tool -id "${EPREFIX}"/${loc} "${ED}"/${loc} || die
+ fi
+}