summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-12-24 18:27:53 +0100
committerAlfredo Tupone <tupone@gentoo.org>2022-12-24 18:28:27 +0100
commit7324eada9db40f31248030db07b71b0864c263e9 (patch)
tree834aafa46b1ce352ebeec6fdaa58a4219e18abf2 /dev-tcltk
parentapp-containers/cri-o: drop 1.25.0, 1.25.1 (diff)
downloadgentoo-7324eada9db40f31248030db07b71b0864c263e9.tar.gz
gentoo-7324eada9db40f31248030db07b71b0864c263e9.tar.bz2
gentoo-7324eada9db40f31248030db07b71b0864c263e9.zip
dev-tcltk/mysqltcl: fix with newer mysql API
Closes: https://bugs.gentoo.org/692562 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/mysqltcl/files/mysqltcl-3.05-API.patch11
-rw-r--r--dev-tcltk/mysqltcl/mysqltcl-3.052-r1.ebuild7
2 files changed, 16 insertions, 2 deletions
diff --git a/dev-tcltk/mysqltcl/files/mysqltcl-3.05-API.patch b/dev-tcltk/mysqltcl/files/mysqltcl-3.05-API.patch
new file mode 100644
index 000000000000..f28f044f850f
--- /dev/null
+++ b/dev-tcltk/mysqltcl/files/mysqltcl-3.05-API.patch
@@ -0,0 +1,11 @@
+--- a/generic/mysqltcl.c 2022-12-24 18:24:12.451620838 +0100
++++ b/generic/mysqltcl.c 2022-12-24 18:24:24.075438534 +0100
+@@ -911,7 +911,7 @@
+ #if (MYSQL_VERSION_ID>=32350)
+ if(mysql_options_reconnect)
+ {
+- my_bool reconnect = 1;
++ bool reconnect = 1;
+ mysql_options(handle->connection, MYSQL_OPT_RECONNECT, &reconnect);
+ }
+ mysql_options(handle->connection,MYSQL_READ_DEFAULT_GROUP,groupname);
diff --git a/dev-tcltk/mysqltcl/mysqltcl-3.052-r1.ebuild b/dev-tcltk/mysqltcl/mysqltcl-3.052-r1.ebuild
index 8023b497b90f..39c9d60a33a9 100644
--- a/dev-tcltk/mysqltcl/mysqltcl-3.052-r1.ebuild
+++ b/dev-tcltk/mysqltcl/mysqltcl-3.052-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -16,7 +16,10 @@ DEPEND="
dev-lang/tcl:0=
dev-db/mysql-connector-c:0="
RDEPEND="${DEPEND}"
-PATCHES=( "${FILESDIR}"/${PN}-3.05-ldflags.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.05-ldflags.patch
+ "${FILESDIR}"/${PN}-3.05-API.patch
+)
HTML_DOCS=( doc/mysqltcl.html )
src_prepare() {