summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-07-18 08:34:01 +0200
committerAlfredo Tupone <tupone@gentoo.org>2022-07-18 08:34:01 +0200
commitf3945e03f09a91f63c9a4068457580d1195a5841 (patch)
tree1cb37316829d6f2fb0a8561aee21cdff4d6b4393 /dev-tcltk
parentdev-lang/teyjus: Use CC,LD,AR,AS,CPP. (diff)
downloadgentoo-f3945e03f09a91f63c9a4068457580d1195a5841.tar.gz
gentoo-f3945e03f09a91f63c9a4068457580d1195a5841.tar.bz2
gentoo-f3945e03f09a91f63c9a4068457580d1195a5841.zip
dev-tcltk/snack: fix type mismatch
Closes: https://bugs.gentoo.org/858263 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/snack/files/snack-2.2.10-lto.patch28
-rw-r--r--dev-tcltk/snack/snack-2.2.10-r9.ebuild1
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-tcltk/snack/files/snack-2.2.10-lto.patch b/dev-tcltk/snack/files/snack-2.2.10-lto.patch
new file mode 100644
index 000000000000..27c6b6c9126f
--- /dev/null
+++ b/dev-tcltk/snack/files/snack-2.2.10-lto.patch
@@ -0,0 +1,28 @@
+--- a/generic/sound.c 2022-07-18 08:21:20.492977432 +0200
++++ b/generic/sound.c 2022-07-18 08:21:44.720698702 +0200
+@@ -120,9 +120,9 @@
+ int littleEndian = 0;
+
+ #ifdef __cplusplus
+-extern "C" SnackStubs *snackStubs;
++extern "C" SnackStubs snackStubs;
+ #else
+-extern SnackStubs *snackStubs;
++extern SnackStubs snackStubs;
+ #endif
+
+ extern Tcl_HashTable *filterHashTable;
+--- a/generic/snack.c 2022-07-18 08:21:29.953868734 +0200
++++ b/generic/snack.c 2022-07-18 08:22:05.978453035 +0200
+@@ -203,9 +203,9 @@
+ int littleEndian = 0;
+
+ #ifdef __cplusplus
+-extern "C" SnackStubs *snackStubs;
++extern "C" SnackStubs snackStubs;
+ #else
+-extern SnackStubs *snackStubs;
++extern SnackStubs snackStubs;
+ #endif
+
+ extern Tcl_HashTable *filterHashTable;
diff --git a/dev-tcltk/snack/snack-2.2.10-r9.ebuild b/dev-tcltk/snack/snack-2.2.10-r9.ebuild
index 4466b95ddb31..d95bd49e31da 100644
--- a/dev-tcltk/snack/snack-2.2.10-r9.ebuild
+++ b/dev-tcltk/snack/snack-2.2.10-r9.ebuild
@@ -37,6 +37,7 @@ PATCHES=(
"${FILESDIR}"/${P}-test.patch
"${FILESDIR}"/${PN}${PV}-seektell-fix.patch
"${FILESDIR}"/tcl-${P}-python3.patch
+ "${FILESDIR}"/${P}-lto.patch
)
HTML_DOCS="${WORKDIR}/${PN}${PV}/doc/*"