summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-tex/latex-beamer
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-tex/latex-beamer')
-rw-r--r--dev-tex/latex-beamer/Manifest2
-rw-r--r--dev-tex/latex-beamer/latex-beamer-3.33.ebuild38
-rw-r--r--dev-tex/latex-beamer/latex-beamer-3.36.ebuild38
-rw-r--r--dev-tex/latex-beamer/metadata.xml8
4 files changed, 86 insertions, 0 deletions
diff --git a/dev-tex/latex-beamer/Manifest b/dev-tex/latex-beamer/Manifest
new file mode 100644
index 000000000000..6447d90270a9
--- /dev/null
+++ b/dev-tex/latex-beamer/Manifest
@@ -0,0 +1,2 @@
+DIST latex-beamer-3.33.zip 4345792 SHA256 a0e59f464d69ed49d5998a674671209f6c7c1a6f095446c236b1144462bfa3b6 SHA512 c6fc019be08d9478b3b83a011d2ef726016581d93e67e37f12058ffd4b8c4889c25ab9c9e56f03d09505c5032fb5fccb7d3f9bf548988511aabe9c403afe42a8 WHIRLPOOL ecbf39035d29af073ca2df73a7689ca280f332d226fab5fa3859f332f76b2ca21e81ebd46d53a821892e9a02d2bdbab87a797bc887b8d44b1dbbdcd139fb05c2
+DIST latex-beamer-3.36.zip 4364333 SHA256 5bd5366da9942cec067dcf8a492d713ff45a73a4a48ff56151fd5ce01488bc63 SHA512 b93d91c2eb523d7e30ecee8fa1af625730bb465124da4f856f7708da32d31fc3bc68e5b57e120b8e39b8ed3b74fef0aeb208b92f4bbdf741c8bf377227fa84cf WHIRLPOOL 22df7b9fd3681b7ea0ada51ce1b71c16b3152e85fc52dfb3c096a1771232c3de7d1c0c2baa935b1d0814ce220208f49094a8a6c295a64d4ebcbe3b234eb11100
diff --git a/dev-tex/latex-beamer/latex-beamer-3.33.ebuild b/dev-tex/latex-beamer/latex-beamer-3.33.ebuild
new file mode 100644
index 000000000000..47fa73112f99
--- /dev/null
+++ b/dev-tex/latex-beamer/latex-beamer-3.33.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit latex-package
+
+DESCRIPTION="LaTeX class for creating presentations using a video projector"
+HOMEPAGE="http://bitbucket.org/rivanvx/beamer/wiki/Home"
+SRC_URI="http://dev.gentoo.org/~radhermit/dist/${P}.zip"
+
+LICENSE="GPL-2 FDL-1.2 LPPL-1.3c"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc examples"
+
+DEPEND="app-arch/unzip
+ dev-texlive/texlive-latex"
+RDEPEND=">=dev-tex/pgf-1.10
+ dev-tex/xcolor
+ !dev-tex/translator"
+
+S=${WORKDIR}/beamer
+
+src_install() {
+ insinto /usr/share/texmf-site/tex/latex/beamer
+ doins -r base
+
+ dodoc AUTHORS ChangeLog README TODO doc/licenses/LICENSE
+
+ if use doc ; then
+ docinto doc
+ dodoc -r doc/*
+ fi
+
+ use examples && dodoc -r examples solutions
+}
diff --git a/dev-tex/latex-beamer/latex-beamer-3.36.ebuild b/dev-tex/latex-beamer/latex-beamer-3.36.ebuild
new file mode 100644
index 000000000000..04272c71f6ca
--- /dev/null
+++ b/dev-tex/latex-beamer/latex-beamer-3.36.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit latex-package
+
+DESCRIPTION="LaTeX class for creating presentations using a video projector"
+HOMEPAGE="http://bitbucket.org/rivanvx/beamer/wiki/Home"
+SRC_URI="http://dev.gentoo.org/~radhermit/dist/${P}.zip"
+
+LICENSE="GPL-2 FDL-1.2 LPPL-1.3c"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc examples"
+
+DEPEND="app-arch/unzip
+ dev-texlive/texlive-latex"
+RDEPEND=">=dev-tex/pgf-1.10
+ dev-tex/xcolor
+ !dev-tex/translator"
+
+S=${WORKDIR}/beamer
+
+src_install() {
+ insinto /usr/share/texmf-site/tex/latex/beamer
+ doins -r base
+
+ dodoc AUTHORS ChangeLog README TODO doc/licenses/LICENSE
+
+ if use doc ; then
+ docinto doc
+ dodoc -r doc/*
+ fi
+
+ use examples && dodoc -r examples solutions
+}
diff --git a/dev-tex/latex-beamer/metadata.xml b/dev-tex/latex-beamer/metadata.xml
new file mode 100644
index 000000000000..a77c37926218
--- /dev/null
+++ b/dev-tex/latex-beamer/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>tex</herd>
+ <upstream>
+ <remote-id type="bitbucket">rivanvx/beamer</remote-id>
+ </upstream>
+</pkgmetadata>