summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2019-11-09 17:51:51 -0500
committerAaron Bauman <bman@gentoo.org>2019-11-09 17:52:10 -0500
commit04661242c7c14b0ade681d124c39ed7564c0d151 (patch)
tree514422d274f23ee1df44f0580ebc13f55c30f612 /dev-tex/svninfo
parentapp-emulation/libpod: fix get_release_info.sh VERSION (diff)
downloadgentoo-04661242c7c14b0ade681d124c39ed7564c0d151.tar.gz
gentoo-04661242c7c14b0ade681d124c39ed7564c0d151.tar.bz2
gentoo-04661242c7c14b0ade681d124c39ed7564c0d151.zip
dev-tex/svninfo: bump EAPI and stuff
Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'dev-tex/svninfo')
-rw-r--r--dev-tex/svninfo/svninfo-0.7.4.ebuild28
1 files changed, 13 insertions, 15 deletions
diff --git a/dev-tex/svninfo/svninfo-0.7.4.ebuild b/dev-tex/svninfo/svninfo-0.7.4.ebuild
index 1e2849117738..6b97d0820bf6 100644
--- a/dev-tex/svninfo/svninfo-0.7.4.ebuild
+++ b/dev-tex/svninfo/svninfo-0.7.4.ebuild
@@ -1,29 +1,27 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
-inherit latex-package eutils
+inherit latex-package
-LICENSE="LPPL-1.2"
DESCRIPTION="A LaTeX module to access SVN version info"
-HOMEPAGE="http://www.brucker.ch/projects/svninfo/index.en.html"
-SRC_URI="http://www.brucker.ch/projects/svninfo/download/${P}.tar.gz"
-SLOT="0"
+HOMEPAGE="https://www.brucker.ch/projects/svninfo/index.en.html"
+SRC_URI="https://www.brucker.ch/projects/svninfo/download/${P}.tar.gz"
+
KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+LICENSE="LPPL-1.2"
+SLOT="0"
IUSE=""
-DOCS="README"
+DOCS=( "README" )
-TEXMF=/usr/share/texmf-site
+PATCHES=( "${FILESDIR}/${PN}-0.5-latex-compile.patch" )
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/${PN}-0.5-latex-compile.patch"
-}
+TEXMF=/usr/share/texmf-site
src_compile() {
export VARTEXFONTS="${T}/fonts"
- emake -j1 || die "compilation failed"
+ emake -j1
}