summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-tex/tth
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-tex/tth')
-rw-r--r--dev-tex/tth/Manifest1
-rw-r--r--dev-tex/tth/metadata.xml5
-rw-r--r--dev-tex/tth/tth-3.77.ebuild36
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-tex/tth/Manifest b/dev-tex/tth/Manifest
new file mode 100644
index 000000000000..a24fdb6a02fd
--- /dev/null
+++ b/dev-tex/tth/Manifest
@@ -0,0 +1 @@
+DIST tth-3.77.tgz 322313 SHA256 2ac11c76cbe21879b8ca3cbd47dd6349adfca869a465870c79f87046432fc28c SHA512 8fabe24172b1ba6ac275e0d3cd8fbb88fbd8fcf15eb7a8a7f99a3f483629d51587f0f97fdca84d86bff9ef57829415e5f026c24338bef75ba867d3a3dfb3bb87 WHIRLPOOL db03565233ce591b100a895aa0f86fa3c78a7b68db8b070634637849bb8b0fb6a1f2eed9c3e7c820ab5f6b38412babe30b5616f46c306da438b1d85804263ebd
diff --git a/dev-tex/tth/metadata.xml b/dev-tex/tth/metadata.xml
new file mode 100644
index 000000000000..21ff3a538481
--- /dev/null
+++ b/dev-tex/tth/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>tex</herd>
+</pkgmetadata>
diff --git a/dev-tex/tth/tth-3.77.ebuild b/dev-tex/tth/tth-3.77.ebuild
new file mode 100644
index 000000000000..ea7b29a8f4ad
--- /dev/null
+++ b/dev-tex/tth/tth-3.77.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit toolchain-funcs
+
+DESCRIPTION="Translate TEX into HTML"
+HOMEPAGE="http://hutchinson.belmont.ma.us/tth/"
+SRC_URI="mirror://gentoo/${P}.tgz"
+
+SLOT="0"
+LICENSE="free-noncomm"
+KEYWORDS="amd64 ~arm hppa ppc ppc64 x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ app-text/ghostscript-gpl
+ media-libs/netpbm"
+
+S="${WORKDIR}/tth_C"
+
+src_compile() {
+ echo 'all: tth' > Makefile || die
+ tc-export CC
+ emake
+}
+
+src_install() {
+ dobin tth latex2gif ps2gif ps2png
+ dodoc CHANGES
+ doman tth.1
+ dohtml *
+}