summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-tex/xymtex
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-tex/xymtex')
-rw-r--r--dev-tex/xymtex/Manifest1
-rw-r--r--dev-tex/xymtex/metadata.xml6
-rw-r--r--dev-tex/xymtex/xymtex-5.00a.ebuild44
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-tex/xymtex/Manifest b/dev-tex/xymtex/Manifest
new file mode 100644
index 000000000000..1d6d1334f434
--- /dev/null
+++ b/dev-tex/xymtex/Manifest
@@ -0,0 +1 @@
+DIST xymtex500a.zip 8362958 SHA256 f7f472e3a47988c6ced0f781b280bea54fa5c6337004d23e1fcf56da58564ebd SHA512 5ee0c13443084dce896d2560561c423d94b1d5e2ab10bd120a957e798de7c11efd192872de2b4b8d7df60a1f126a368e5d1dbdb90ce6055b9ab6067a71668fe3 WHIRLPOOL d769a243b3da5483652ebe165fc15e34bc9f78f2fbdbd83c380da7b4a15ab72f467911dc43e9eba1b1512eff7f7981b0d82c49a239824fab333cb2bc9641a052
diff --git a/dev-tex/xymtex/metadata.xml b/dev-tex/xymtex/metadata.xml
new file mode 100644
index 000000000000..a6a645317dfb
--- /dev/null
+++ b/dev-tex/xymtex/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>tex</herd>
+<herd>sci</herd>
+</pkgmetadata>
diff --git a/dev-tex/xymtex/xymtex-5.00a.ebuild b/dev-tex/xymtex/xymtex-5.00a.ebuild
new file mode 100644
index 000000000000..14b68cc69120
--- /dev/null
+++ b/dev-tex/xymtex/xymtex-5.00a.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit latex-package versionator
+
+DESCRIPTION="LaTeX package for rendering high-quality chemical structure diagrams"
+HOMEPAGE="http://xymtex.com/"
+MY_PV="$(delete_all_version_separators)"
+SRC_URI="${HOMEPAGE}/fujitas3/${PN}/xym${MY_PV}/xym-up/${PN}${MY_PV}.zip"
+LICENSE="LPPL-1.3"
+
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S="${WORKDIR}/${PN}"
+
+TEXMF=/usr/share/texmf-site
+
+src_compile() {
+ local subdir
+ for subdir in base chemist xymtxpdf xymtxps; do
+ cd "${S}/${subdir}" || die
+ latex-package_src_compile
+ done
+}
+
+src_install() {
+ local subdir
+ for subdir in base chemist xymtxpdf xymtxps; do
+ cd "${S}/${subdir}" || die
+ latex-package_src_install
+ done
+
+ # cd "${S}/doc/doc${MY_PV}/" || die
+ cd "${S}/doc/doc500/" || die
+ latex-package_src_doinstall pdf
+}