summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Korepanov <kaikaikai@yandex.ru>2019-06-17 19:52:03 +0100
committerMikle Kolyada <zlogene@gentoo.org>2019-06-24 20:14:28 +0300
commita90553097ac89cf07e28263e30695c1ba8616cc2 (patch)
treec7aeac19bb22535a2a4d5cbe58925b3cacefa114 /dev-tex
parentdev-ada/libadalang: fix dependency (diff)
downloadgentoo-a90553097ac89cf07e28263e30695c1ba8616cc2.tar.gz
gentoo-a90553097ac89cf07e28263e30695c1ba8616cc2.tar.bz2
gentoo-a90553097ac89cf07e28263e30695c1ba8616cc2.zip
dev-tex/latexdiff: 1.3.0 version bump
Signed-off-by: Alexey Korepanov <kaikaikai@yandex.ru> Closes: https://bugs.gentoo.org/688228 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'dev-tex')
-rw-r--r--dev-tex/latexdiff/Manifest1
-rw-r--r--dev-tex/latexdiff/latexdiff-1.3.0.ebuild49
-rw-r--r--dev-tex/latexdiff/latexdiff-9999.ebuild10
3 files changed, 56 insertions, 4 deletions
diff --git a/dev-tex/latexdiff/Manifest b/dev-tex/latexdiff/Manifest
index 3145619bd9f0..c2d082adc2fb 100644
--- a/dev-tex/latexdiff/Manifest
+++ b/dev-tex/latexdiff/Manifest
@@ -1,2 +1,3 @@
DIST latexdiff-1.1.0.zip 466029 BLAKE2B 5efe78845f6bcd2a3c8af8e889cb868047a8131268e903bc465068fd1f9de419426738eb1d4014ca92adf28714a6af0650cfe03c31f4303830978f558c15c225 SHA512 04af20386b0e611f73d981242747316da6376967fef611a29927b66a7a129bec49c7224655378c6f9fc744f8d69cf2ac977d0f50278d3686c98dcdc4aef0b675
DIST latexdiff-1.2.1.tar.gz 1780064 BLAKE2B d657d5d36bcb759889a582b4aac38ae67d99a17bc30fb37d627e9d496df40a1523871e31968333f07b1ad94b521faf91336b225f7466ef382713d48a803f1444 SHA512 9917a0eee36e5bff7c13e5690e743fa34aa7c1347a6509961aa4484094433854c6742a4c1605087db1902a57537fda2b49b071e98b015a5535379c27ccc1fd46
+DIST latexdiff-1.3.0.tar.gz 1791127 BLAKE2B e394dcf29d529f47a87eb7615d0da42a2d30c0e3a40938903cee75c2241ee8543713ee735f94f9eb9fe59829be85a5dad681183d96b2651e0e09d20ecae9e207 SHA512 d1b47ff4733bbba0ecadd71e6c54362b78ad8e97cac54b99b9ead4565dd0a56a8a5d4ce27866cabb4dc43c47a3c2230ce7743909f2d30bb94ecbae75c6ecbaae
diff --git a/dev-tex/latexdiff/latexdiff-1.3.0.ebuild b/dev-tex/latexdiff/latexdiff-1.3.0.ebuild
new file mode 100644
index 000000000000..d293d8d31f6c
--- /dev/null
+++ b/dev-tex/latexdiff/latexdiff-1.3.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Compare two latex files and mark up significant differences"
+HOMEPAGE="https://www.ctan.org/tex-archive/support/latexdiff/ https://github.com/ftilmann/latexdiff/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ftilmann/latexdiff.git"
+else
+ SRC_URI="https://github.com/ftilmann/latexdiff/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+IUSE="test"
+
+RDEPEND="
+ >=dev-lang/perl-5.8
+ virtual/latex-base
+ dev-texlive/texlive-plaingeneric
+ dev-perl/Algorithm-Diff
+"
+DEPEND="${RDEPEND}
+ dev-perl/Pod-LaTeX
+"
+BDEPEND="
+ test? ( app-shells/tcsh )
+"
+
+src_compile() {
+ export VARTEXFONTS="${T}/fonts"
+ PATH="${S}/dist:${PATH}" emake -j1 distribution
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ cd dist || die
+ dobin latexdiff latexrevise latexdiff-vc
+ doman latexdiff.1 latexrevise.1 latexdiff-vc.1
+ dodoc README doc/latexdiff-man.pdf
+}
diff --git a/dev-tex/latexdiff/latexdiff-9999.ebuild b/dev-tex/latexdiff/latexdiff-9999.ebuild
index c68835644e52..d293d8d31f6c 100644
--- a/dev-tex/latexdiff/latexdiff-9999.ebuild
+++ b/dev-tex/latexdiff/latexdiff-9999.ebuild
@@ -1,17 +1,17 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
DESCRIPTION="Compare two latex files and mark up significant differences"
-HOMEPAGE="http://www.ctan.org/tex-archive/support/latexdiff/ https://github.com/ftilmann/latexdiff/"
+HOMEPAGE="https://www.ctan.org/tex-archive/support/latexdiff/ https://github.com/ftilmann/latexdiff/"
if [[ ${PV} == *9999* ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/ftilmann/latexdiff.git"
else
SRC_URI="https://github.com/ftilmann/latexdiff/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~s390 ~sh ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
fi
LICENSE="GPL-3"
@@ -27,6 +27,8 @@ RDEPEND="
"
DEPEND="${RDEPEND}
dev-perl/Pod-LaTeX
+"
+BDEPEND="
test? ( app-shells/tcsh )
"