summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2018-06-24 16:25:21 +0800
committerJason Zaman <perfinion@gentoo.org>2018-06-24 16:25:32 +0800
commit4df9c26f0de7d3d83f275b11aaef4564a947fa5f (patch)
tree1da3282c00cb4b074dcc3096adb6b4b6f84167a9 /dev-util/android-studio
parentdev-python/python-axolotl: New package (diff)
downloadgentoo-4df9c26f0de7d3d83f275b11aaef4564a947fa5f.tar.gz
gentoo-4df9c26f0de7d3d83f275b11aaef4564a947fa5f.tar.bz2
gentoo-4df9c26f0de7d3d83f275b11aaef4564a947fa5f.zip
dev-util/android-studio: bump to 3.1.3.0
Closes: https://bugs.gentoo.org/658616 Closes: https://bugs.gentoo.org/613868 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-util/android-studio')
-rw-r--r--dev-util/android-studio/Manifest1
-rw-r--r--dev-util/android-studio/android-studio-3.1.3.0.173.4819257.ebuild108
2 files changed, 109 insertions, 0 deletions
diff --git a/dev-util/android-studio/Manifest b/dev-util/android-studio/Manifest
index 47b81090cb6f..fa9cc6ef8029 100644
--- a/dev-util/android-studio/Manifest
+++ b/dev-util/android-studio/Manifest
@@ -1 +1,2 @@
DIST android-studio-ide-173.4720617-linux.zip 894052929 BLAKE2B cc1ff03b24febf18e8ebd9a78ae0463e9552e20ee4c28e60e5e4f52379e66d6e5c6d91af1cd641b79c72590a081770a22882539612028915cd064834c8bc0ef3 SHA512 121d5eead42743127dfccf37b0b4bc4ceddc0df706bdddbc8c0ae2ec3711b4c8308d945b92ed5e8b3209d380e202dc08fbf8475ef6ad30016ca5cc9acb264d3e
+DIST android-studio-ide-173.4819257-linux.zip 894877040 BLAKE2B 159d57c0c0d6d6958d1a08e7ff4ff0314c0cb2b15c5126dd3d357e1dc696d32dfee78ae6b2d35a628cbf000bc014d61c20ad48acce12c10356b0db8183c27318 SHA512 c399897bc85ce1399ac8ce1df4749d7f1bff4501cb90b13efbd61a56173ab1f6f9b0c7c1f852dceb7a76bc631d83ca4efab9b39c4d3c76e3b4454f4803611251
diff --git a/dev-util/android-studio/android-studio-3.1.3.0.173.4819257.ebuild b/dev-util/android-studio/android-studio-3.1.3.0.173.4819257.ebuild
new file mode 100644
index 000000000000..1ac8561ea03c
--- /dev/null
+++ b/dev-util/android-studio/android-studio-3.1.3.0.173.4819257.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils java-pkg-2 eapi7-ver
+
+RESTRICT="strip"
+QA_PREBUILT="opt/${PN}/bin/libbreakgen*.so
+ opt/${PN}/bin/fsnotifier*
+ opt/${PN}/lib/libpty/linux/x86*/libpty.so
+ opt/${PN}/plugins/android/lib/libwebp_jni*.so
+ opt/${PN}/plugins/android/resources/perfa/*/libperfa.so
+ opt/${PN}/plugins/android/resources/perfd/*/perfd
+ opt/${PN}/plugins/android/resources/simpleperf/*/simpleperf"
+
+VER_CMP=( $(ver_rs 1- ' ') )
+if [[ ${#VER_CMP[@]} -eq 6 ]]; then
+ STUDIO_V=$(ver_cut 1-4)
+ BUILD_V=$(ver_cut 5-6)
+else
+ STUDIO_V=$(ver_cut 1-3)
+ BUILD_V=$(ver_cut 4-5)
+fi
+
+DESCRIPTION="A new Android development environment based on IntelliJ IDEA"
+HOMEPAGE="http://developer.android.com/sdk/installing/studio.html"
+SRC_URI="https://dl.google.com/dl/android/studio/ide-zips/${STUDIO_V}/${PN}-ide-${BUILD_V}-linux.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="selinux"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="app-arch/zip
+ dev-java/commons-logging:0
+ dev-java/log4j:0"
+
+# dev-java/guava:18
+RDEPEND=">=virtual/jdk-1.7
+ selinux? ( sec-policy/selinux-android )
+ >=app-arch/bzip2-1.0.6-r4
+ dev-java/commons-logging:0
+ dev-java/log4j:0
+ >=dev-libs/expat-2.1.0-r3
+ >=dev-libs/libffi-3.0.13-r1
+ >=media-libs/fontconfig-2.10.92
+ >=media-libs/freetype-2.5.5
+ >=media-libs/libpng-1.2.51
+ >=media-libs/mesa-10.2.8
+ || ( gnome-extra/zenity kde-apps/kdialog x11-apps/xmessage x11-libs/libnotify )
+ >=sys-libs/ncurses-5.9-r3:5/5[tinfo]
+ >=sys-libs/zlib-1.2.8-r1
+ >=x11-libs/libX11-1.6.2
+ >=x11-libs/libXau-1.0.7-r1
+ >=x11-libs/libXdamage-1.1.4-r1
+ >=x11-libs/libXdmcp-1.1.1-r1
+ >=x11-libs/libXext-1.3.2
+ >=x11-libs/libXfixes-5.0.1
+ >=x11-libs/libXrender-0.9.8
+ >=x11-libs/libXxf86vm-1.1.3
+ >=x11-libs/libdrm-2.4.46
+ >=x11-libs/libxcb-1.9.1
+ >=x11-libs/libxshmfence-1.1"
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ eapply_user
+ # This is really a bundled jdk not a jre
+ rm -R "${S}/jre" || die "Could not remove bundled jdk"
+
+ # Replace bundled jars with system
+ # has problems with newer jdom:0 not updated to jdom:2
+ cd "${S}/lib" || die
+ local JARS="commons-logging log4j"
+ local j
+ for j in ${JARS}; do
+ rm -v ${j/:*/}*.jar || die
+ java-pkg_jar-from ${j}
+ done
+
+ cd "${S}" || die
+
+ # bug 629404
+ echo "-Djdk.util.zip.ensureTrailingSlash=false" >> bin/studio64.vmoptions || die
+ echo "-Djdk.util.zip.ensureTrailingSlash=false" >> bin/studio.vmoptions || die
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ local dir="/opt/${PN}"
+
+ insinto "${dir}"
+ # Replaced bundled jre with system vm/jdk
+ # This is really a bundled jdk not a jre
+ doins -r *
+
+ rm -rf "${D}${dir}/jre" || die
+
+ fperms 755 "${dir}/bin/studio.sh" "${dir}"/bin/fsnotifier{,64}
+ chmod 755 "${D}${dir}"/gradle/gradle-*/bin/gradle || die
+
+ newicon "bin/studio.png" "${PN}.png"
+ make_wrapper ${PN} ${dir}/bin/studio.sh
+ make_desktop_entry ${PN} "Android Studio" ${PN} "Development;IDE" "StartupWMClass=jetbrains-studio"
+}