summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2017-07-08 14:24:18 +0800
committerJason Zaman <perfinion@gentoo.org>2017-07-08 17:05:10 +0800
commitb5e700ee1928288cc91fdf80daae8ee500d3bd71 (patch)
treea6d5025bed11030744ef913d43dcc5abb2c4ddb2 /dev-util/android-studio
parentdev-util/android-studio: stable 2.3.2 (diff)
downloadgentoo-b5e700ee1928288cc91fdf80daae8ee500d3bd71.tar.gz
gentoo-b5e700ee1928288cc91fdf80daae8ee500d3bd71.tar.bz2
gentoo-b5e700ee1928288cc91fdf80daae8ee500d3bd71.zip
dev-util/android-studio: bump to 2.3.3
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'dev-util/android-studio')
-rw-r--r--dev-util/android-studio/Manifest1
-rw-r--r--dev-util/android-studio/android-studio-2.3.3.0.162.4069837.ebuild99
2 files changed, 100 insertions, 0 deletions
diff --git a/dev-util/android-studio/Manifest b/dev-util/android-studio/Manifest
index bd348d6ce204..c6cb23785b6a 100644
--- a/dev-util/android-studio/Manifest
+++ b/dev-util/android-studio/Manifest
@@ -1,2 +1,3 @@
DIST android-studio-ide-162.3871768-linux.zip 450391500 SHA256 36520f21678f80298b5df5fe5956db17a5984576f895fdcaa36ab0dbfb408433 SHA512 af49146ac2c744f75c563ff00a48805c5edac8a8f0b38d42179384d3fc8188f648ce6974f8b1312bfc52449285063c78acda609199d38397cbd4e319a2cee206 WHIRLPOOL 1e8106bfb7bc785861edfb6891b6e25618abfd1818130c1b854a3e887beb2cf98011ee16af1bcf21f1552fdbce2ff55c55d0c490e92d7f5b3ef8ee23cf440b5d
DIST android-studio-ide-162.3934792-linux.zip 459976690 SHA256 6e33a232466820a15c884af9faefab772b8267ede056aaedb63f291ceb5e95a7 SHA512 ff563d4c1adca5ae153bf23cde39cda4b462097706e92eb09e9850b07902388cdc569e479d7c8be7d27dca24f897797810534e54a113d043436c312637d62184 WHIRLPOOL 3d44bf16988c280d5ee6df1ee9a7c664a46a58107a73d001d493580f6ca365428a164a5ab9a6fb48fce730c0a19bc3b82a0f891c23131755c659842fe506aa3d
+DIST android-studio-ide-162.4069837-linux.zip 490782431 SHA256 1383cfd47441e5f820b6257a1bdd683e0e980bc76c7f2027ef84dc2e6ad2f17f SHA512 44f093ce4c97211913bb979fb28d5fe43163462ce6153c31c03576d872e11cbc11651f10397e14247ca41ea269a3cb0998e9e7d37fc63ac6782cc653037d925c WHIRLPOOL ed833816f48abba51d8142fda91175c07f019f40a3ed21ea026367870723016c17262c0eccb71d3d85a5f963ca0a84b0ee2111ae15f95ad92ac565f225d6c10a
diff --git a/dev-util/android-studio/android-studio-2.3.3.0.162.4069837.ebuild b/dev-util/android-studio/android-studio-2.3.3.0.162.4069837.ebuild
new file mode 100644
index 000000000000..40da7d6a297d
--- /dev/null
+++ b/dev-util/android-studio/android-studio-2.3.3.0.162.4069837.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils java-pkg-2 versionator
+
+RESTRICT="strip"
+QA_PREBUILT="opt/${PN}/bin/libbreakgen*.so
+ opt/${PN}/bin/fsnotifier*
+ opt/${PN}/lib/libpty/linux/x86*/libpty.so
+ opt/${PN}/plugins/android/lib/libwebp_jni*.so"
+
+if [[ $(get_version_component_count) -eq 6 ]]; then
+ STUDIO_V=$(get_version_component_range 1-4)
+ BUILD_V=$(get_version_component_range 5-6)
+else
+ STUDIO_V=$(get_version_component_range 1-3)
+ BUILD_V=$(get_version_component_range 4-5)
+fi
+
+DESCRIPTION="A new Android development environment based on IntelliJ IDEA"
+HOMEPAGE="http://developer.android.com/sdk/installing/studio.html"
+SRC_URI="https://dl.google.com/dl/android/studio/ide-zips/${STUDIO_V}/${PN}-ide-${BUILD_V}-linux.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="selinux"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="app-arch/zip
+ dev-java/commons-logging:0
+ dev-java/log4j:0"
+
+# dev-java/guava:18
+RDEPEND=">=virtual/jdk-1.7
+ selinux? ( sec-policy/selinux-android )
+ >=app-arch/bzip2-1.0.6-r4
+ dev-java/commons-logging:0
+ dev-java/log4j:0
+ >=dev-libs/expat-2.1.0-r3
+ >=dev-libs/libffi-3.0.13-r1
+ >=media-libs/fontconfig-2.10.92
+ >=media-libs/freetype-2.5.5
+ >=media-libs/libpng-1.2.51
+ >=media-libs/mesa-10.2.8
+ || ( gnome-extra/zenity kde-apps/kdialog x11-apps/xmessage x11-libs/libnotify )
+ || ( >=sys-libs/ncurses-5.9-r3:5/5[tinfo] >=sys-libs/ncurses-5.9-r3:0/5[tinfo] )
+ >=sys-libs/zlib-1.2.8-r1
+ >=x11-libs/libX11-1.6.2
+ >=x11-libs/libXau-1.0.7-r1
+ >=x11-libs/libXdamage-1.1.4-r1
+ >=x11-libs/libXdmcp-1.1.1-r1
+ >=x11-libs/libXext-1.3.2
+ >=x11-libs/libXfixes-5.0.1
+ >=x11-libs/libXrender-0.9.8
+ >=x11-libs/libXxf86vm-1.1.3
+ >=x11-libs/libdrm-2.4.46
+ >=x11-libs/libxcb-1.9.1
+ >=x11-libs/libxshmfence-1.1"
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ eapply_user
+ # This is really a bundled jdk not a jre
+ rm -R "${S}/jre" || die "Could not remove bundled jdk"
+
+ # Replace bundled jars with system
+ # has problems with newer jdom:0 not updated to jdom:2
+ cd "${S}/lib" || die
+ local JARS="commons-logging log4j"
+ local j
+ for j in ${JARS}; do
+ rm -v ${j/:*/}*.jar || die
+ java-pkg_jar-from ${j}
+ done
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ local dir="/opt/${PN}"
+
+ insinto "${dir}"
+ # Replaced bundled jre with system vm/jdk
+ # This is really a bundled jdk not a jre
+ doins -r *
+
+ rm -rf "${D}${dir}/jre" || die
+ dosym "/etc/java-config-2/current-system-vm" "${dir}/jre"
+
+ fperms 755 "${dir}/bin/studio.sh" "${dir}"/bin/fsnotifier{,64}
+ chmod 755 "${D}${dir}"/gradle/gradle-*/bin/gradle || die
+
+ newicon "bin/studio.png" "${PN}.png"
+ make_wrapper ${PN} ${dir}/bin/studio.sh
+ make_desktop_entry ${PN} "Android Studio" ${PN} "Development;IDE"
+}